Refresh directory after operation not working

Advertisement

44nonymous
Joined:
Posts:
19

Refresh directory after operation not working

"Refresh remote panel every" is disabled.

I have to manually refresh the directory after any operation like uploading a new file.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,736
Location:
Prague, Czechia

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

44nonymous
Joined:
Posts:
19

This is how to reproduce the bug:

- If transfer in background is enabled, refreshing the file list after any operation (upload, delete, etc) never happens.

- If transfer in background is disabled, a popup window shows, and after it closes refresh works fine.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,736
Location:
Prague, Czechia

44nonymous wrote:

This is how to reproduce the bug:

- If transfer in background is enabled, refreshing the file list after any operation (upload, delete, etc) never happens.

- If transfer in background is disabled, a popup window shows, and after it closes refresh works fine.
Don't you have directory caching disabled?
https://winscp.net/eng/docs/ui_login_directories#directory_reading_options

Reply with quote

44nonymous

Directory caching does not matter. I can reproduce the bug the same way with it enabled and disabled.

Enabling Transfer in background causes the problem. I had to try every possible setting until I found out what was causing the bug.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,736
Location:
Prague, Czechia

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,736
Location:
Prague, Czechia

As I have asked you already:
In your log:
. 2020-02-13 05:37:12.921 Local directory: ...,  Cache: No
...
. 2020-02-13 05:37:18.062 Not refreshing directory, caching is off.

If you can reproduce the problem even with enabled caching (as you have claimed), please post a log file for that.

Reply with quote

44nonymous
Joined:
Posts:
19

Come on give me some credit. I can't do it right now, I'm not using that computer.

Why do you need any caching to force refresh after any operation?. It makes no sense, but I TRIED IT TOO and it makes no difference.

Thanks.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,736
Location:
Prague, Czechia

44nonymous wrote:

Why do you need any caching to force refresh after any operation?
It's just the way it is.

But I TRIED IT TOO and it makes no difference.
Post a log file for that.

Reply with quote

44nonymous
Joined:
Posts:
19

martin wrote:

44nonymous wrote:

Why do you need any caching to force refresh after any operation?
It's just the way it is

It is not. If you disable Transfer in background (all cache options off), forcing autorefresh after any operation works perfectly.

You provide log of the opposite. I give up. This bug will stay forever, it was reported more than 5 years ago

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,736
Location:
Prague, Czechia

44nonymous wrote:

It is not. If you disable Transfer in background (all cache options off), forcing autorefresh after any operation works perfectly.
That's true. I never claimed opposite. But for refresh after background transfer, the caching needs to be enabled. It's not a bug. It's the way it is implemented. I understand that you may not like it. But no one else have problems with it, so it's not likely I'm going to re-implement it.

Reply with quote

Advertisement

You can post new topics in this forum