Synchronize Problem -special Filenames

Advertisement

sixta
Joined:
Posts:
2
Location:
Ebersberg

Synchronize Problem -special Filenames

Hi,
we try to synchronize a path (we know the path name is very special), script:

open ftp:bla….
option failonnomatch off
option confirm off
option batch continue
synchronize remote -delete -mirror "D:\Gemeinsame Ordner\4) ToDo Kroiß\sfirm\Banking\sf_dat" "/Gemeinsame Ordner/4) ToDo Kroiß/sfirm/Banking/sf_dat"
exit

We get always the same error messages see winscp2.jpg.
When we look at the FTP-Server, the files exist locally and remotely see winscp1.jpg.
Why do we get the error messages?
  • winscpImg.zip (112.49 KB, Private file)
Description: zip-File containing winscp1.jpg and winscp2.jpg

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,766
Location:
Prague, Czechia

Re: Synchronize Problem -special Filenames

Make sure you use the latest version of WinSCP and that your script file uses UTF-8 encoding.
See https://winscp.net/eng/docs/scripting#using_scripting

If this does not help, please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

sixta
Joined:
Posts:
2
Location:
Ebersberg

Thank you for the quick reply.
I think it has nothing to do with UTF-8.
But looking exactly at the logfile, I got it. The user named the file with a leading blank.
Have a look at D:\datex\ Datenbank-..., there is a blank before "Datenbank..."
No idea how he managed it on a windows system ...
To proof this, I have isolated the files and got the following log-file:
Verbinde mit backup.serverkompetenz.de ...
Verbunden
Starte die Sitzung...
Sitzung gestartet.
Aktive Sitzung: [1] user@backup.serverkompetenz.de
failonnomatch   off       
confirm         off       
batch           continue  
Vergleiche...
Lokal 'D:\datex' => Entfernt '/datex'
Synchronisiere...
Lokal 'D:\datex' => Entfernt '/datex'
D:\datex\ Datenbank-Inhaltsabgleich _20131025-1022.htm |         197 KB | 1155,9 KB/s | binary | 100%
D:\datex\ Datenbank-Inhaltsabgleich _20140114-1439.htm |           2 KB |  782,2 KB/s | binary | 100%
D:\datex\ Datenbank-Inhaltsabgleich _20150121-0831.htm |           1 KB |  623,8 KB/s | binary | 100%
D:\datex\a.diener.prf.lock |           29 B |  514,7 KB/s | binary | 100%
Fehler beim Löschen der Datei '/datex/Datenbank-Inhaltsabgleich _20131025-1022.htm'.
/datex/Datenbank-Inhaltsabgleich _20131025-1022.htm: Datei oder Verzeichnis nicht gefunden
A(b)brechen, (W)iederholen, Über(s)pringen, (A)lle überspringen: Überspringen
'/datex/Datenbank-Inhaltsabgleich _20131025-1022.htm' gelöscht
Fehler beim Löschen der Datei '/datex/Datenbank-Inhaltsabgleich _20140114-1439.htm'.
/datex/Datenbank-Inhaltsabgleich _20140114-1439.htm: Datei oder Verzeichnis nicht gefunden
A(b)brechen, (W)iederholen, Über(s)pringen, (A)lle überspringen: Überspringen
'/datex/Datenbank-Inhaltsabgleich _20140114-1439.htm' gelöscht
Fehler beim Löschen der Datei '/datex/Datenbank-Inhaltsabgleich _20150121-0831.htm'.
/datex/Datenbank-Inhaltsabgleich _20150121-0831.htm: Datei oder Verzeichnis nicht gefunden
A(b)brechen, (W)iederholen, Über(s)pringen, (A)lle überspringen: Überspringen
'/datex/Datenbank-Inhaltsabgleich _20150121-0831.htm' gelöscht
D:\datex\test.txt         |            0 B |    0,0 KB/s | binary |   0%
Sitzung 'user@backup.serverkompetenz.de' geschlossen.
Keine Sitzung

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
31,766
Location:
Prague, Czechia

So can you attach (not post) your script for that? I do not see any Datex in your original script.

Reply with quote

Guest

martin wrote:

So can you attach (not post) your script for that? I do not see any Datex in your original script.

Here it is:

open ftp://user:password@server.de/
option failonnomatch off
option confirm off
option batch continue
synchronize remote -delete -mirror "D:\datex" "/datex"
close
exit

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,766
Location:
Prague, Czechia

Thanks. Can you attach a complete session log file as well?

Reply with quote

Advertisement

You can post new topics in this forum