New files seem to transfer in WinSCP, but my website doesn't update

Advertisement

MarkM
Joined:
Posts:
3
Location:
California

New files seem to transfer in WinSCP, but my website doesn't update

I've been using WinSCP for several years for my (very basic) website, and I always found it to be dependable, and simple enough for me to use (which means VERY simple).

I have a basic website with only html and jpg files, and I occasionally add or update files, and have never had a problem. Recently, I downloaded the latest version of WinSCP and attempted to revise a file, as I've done many times in the past. Everything seems to go as expected when I moved the new file, with no errors messages, but the new file doesn't show up on my website.

(To explain further, I had some text on my index.html page that I wanted to remove. I opened the file, removed the text, saved the file, and tried to transfer it using WinSCP. Everything looked OK, but the text still appears on my webpage.)

Any suggestions or assistance would be greatly appreciated.

Thanks,
Mark

Reply with quote

Advertisement

MrCalvin
Joined:
Posts:
14
Location:
DK

Re: New files seem to transfer in Win SCP, but my website doesn't update

First make sure if the changed file is actually transferred to the server.
If so the problem is not related to WinSCP.
To check:
Connect directly to the server console with SSH and see the content using "cat FullFilePath".
(assuming your web-server is Linux).

Reply with quote

Advertisement

Guest

Two simple variations can also be tried here for your skill level or any level as these are what I would do:

1. Try a private browser window and open the web page there. (Although time already could possibly have seen it change since you first posted). Also as another alternative I may do is to open a different browser and try from there.

2. Copy the file from the site hosting either to your computer or whatever and then delete it on the hosting server and upload the newly changed file. Then see if the site changes.

Of course, if you transfer down to your computer and that works then transfer up should also be expected to be working fine, and so changes just aren't being seen. Especially, if WinSCP doesn't see any errors.

Reply with quote

Advertisement

You can post new topics in this forum