Cannot logon using non-default "SFTP Server" option

Advertisement

MrCalvin
Joined:
Posts:
11
Location:
DK

Cannot logon using non-default "SFTP Server" option

I'm only able to connect with SFTP when using "SFTP Option=Default".
I've tried "SFTP Option=/bin/sftp" (I only have "/bin/sftp" on the server), but I get error 1.
I logon as root user.
Been looking for answers in the WinSCP log-file (Debug 2) but without luck.
Server is Debian Buster.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,665
Location:
Prague, Czechia

Re: Cannot logon using non-default "SFTP Server" option

I'm not sure what you mean by "SFTP Option". Do you mean "SFTP server" session setting?
https://winscp.net/eng/docs/ui_login_sftp
There you need to specify an SFTP server. sftp is a client.
What are you trying to achieve?

Reply with quote

MrCalvin
Joined:
Posts:
11
Location:
DK

Re: Cannot logon using non-default "SFTP Server" option

Yes, the "SFTP server" value (see screen-dump)

The documentation says "Use SFTP server to specify path to SFTP server binary".
I assume it is the binary of SFTP-server/daemon on the remote server, right?
How is this relevant for the client (WinSCP)? The client just connect on port 22 using some protocol and cannot instruct the remote-server on which binary/server/daemon to use (or can it, does it first connect with SSH and the tell the remote-server to switch to SFTP, and thereby which binary to start?)

Description: screen-dump

SFTP.jpg

Reply with quote

martin
Site Admin
martin avatar

Re: Cannot logon using non-default "SFTP Server" option

Yes, SFTP client can instruct the SSH server what binary to execute.

Again, what are you trying to achieve?

Reply with quote

Advertisement

You can post new topics in this forum