[WebDav] [Explorer] Could not display or browse folder of special character

Advertisement

gautthntemp1
Guest

[WebDav] [Explorer] Could not display or browse folder of special character

I using WinSCP to access OneDrive through WebDav.
Today I saw the bug where file/folder with special characters would not display on the explorer or tree section. I attached the image. Like folder of "Visual C#" or "Visual C++" is disappeared. If I force it using the Synchronize Browsing, it would somehow display until the "Visual C" of that folder and its children items' name.
Also I have a long file name that also not listed. I think it have 98 chars with spaces. Using Windows WebDav, I saw it name converted to ^J for many spaces at the end.
Also the selected item in Tree Directory would have black text on black background on Un-focus.
Sorry for long/multiple bugs report

2020-02-09_02-51-34.png

2020-02-09_02-53-02.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,631
Location:
Prague, Czechia

Re: [WebDav] [Explorer] Could not display or browse folder of special character

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
32,631
Location:
Prague, Czechia

Re: [WebDav] [Explorer] Could not display or browse folder of special character

OK, I was able to reproduce the issue.

The thing is that when there is a # or + sign in the filename, OneDrive "converts" it to ^N or ^M in a URL:
<D:href>https://d.docs.live.net/02DE3AAC2A61493F/Test/Visual C^N</D:href>

What is strange choice, as while # and + have indeed special meaning in URLs and need to be somehow encoded, the ^ is invalid character in URL. So WinSCP (rightly) skips that entry as invalid.
https://meta.stackexchange.com/q/69369/218578#69371

Reply with quote

gautthntemp
Joined:
Posts:
1

Hey Martin,
Sorry for late response. I saw that you able to reproduce.
I wonder if you still need any log
Then I wonder if you think this is a bug to fix or would be a NoFix as it is kind of out URL spec but I think other would run into this issue too.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
32,631
Location:
Prague, Czechia

It's not a bug on WinSCP side. But as it's a major server, and I doubt they will fix it, we might implement a workaround, if there's enough demand.
You can vote for it here:
https://winscp.net/tracker/1824

Reply with quote

Advertisement

You can post new topics in this forum