Vax FTP adding $ character before any uppercase letter

Advertisement

rdpetruska
Joined:
Posts:
4
Location:
USA

Vax FTP adding $ character before any uppercase letter

I am running version 5.17.5 on Windows 10 computer. This is not a new issue - I've encountered it with many versions which I can remember.
I am connected via FTP to a Vax (Charon Vax simulator running VMS v5.5-2). Whenever I upload a file from my Windows computer, if there is an uppercase letter in the file name (e.g. DCR.ABL), it appears in the commander remote pane exactly as it appears on the local pane. However, when I use Putty to connect to the vax and go to that directory, the file will be named $dcr.abl in the above example. If there are any numeric characters in the file name, then a $ will be before each starting letter (e.g. U42.JED on my Windows host becomes $u42.$jed on the remote vax).
If I connect via a command prompt from Windows, and use the built-in FTP put command, this does not occur.
I've been searching through the program settings and cannot find any appropriate setting to change to alter this behavior. Any help would be appreciated.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Re: Vax FTP adding $ character before any uppercase letter

WinSCP definitely does not add the $ to the file name.

If you want us to investigate further, please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

rdpetruska
Joined:
Posts:
4
Location:
USA

Martin,
Thanks for responding. I did not think it was WinSCP itself inserting the $ characters, but whatever mode it is using to send the file, the Vax interprets the name differently than command line FTP.
I've attached the log file and 2 screenshots taken after the transfer - one showing the WinSCP window, and another the PuTTY window.
  • FileOnVax.png (29.98 KB, Private file)
  • FileOnVax_viaWinSCP.png (74.02 KB, Private file)
  • generic@wcdc04.pgh.wec.com.log (35.88 KB, Private file)
Description: Log file

Reply with quote

rdpetruska
Joined:
Posts:
4
Location:
USA

Log created this morning.
Thank you for looking into this.

Description: Screenshot of PuTTY session after command line FTP uploaded file.

FileOnVax2.png

  • PAL_Command_FTP_Log.txt (8.1 KB, Private file)
Description: Log file of command line FTP with debug on. Now has snippet from a second session where I typed the filename in uppercase letters exactly as the local Windows directory shows. PuTTY displayed identical, so no new screenshot taken.

Reply with quote

Advertisement

martin
Site Admin
martin avatar

The server behaves differently in WinSCP and ftp logs (compare the responses to the STOR command).
Doesn't the server switch to another mode, if you use unix-like path as you use with WinSCP? – /ug/generic – Contrary to UG:[GENERIC.PRODUCT_LIB.PAL.M12.U42] in ftp.

Reply with quote

rdpetruska
Joined:
Posts:
4
Location:
USA

Just tried it that way, and yes - command line FTP does add the $. ftp dir shows 28612A2.ABL while PuTTY shows 28612$A2.ABL.

Is there some kind of setting/switch within WinSCP that can change this behavior? I've only navigated by using the explorer pane, double-clicking the folder to change to that directory, and either drag/drop, or use the Upload button, to transfer files.
  • PAL_Command_FTP_Log.txt (10.03 KB, Private file)
Description: Updated log output

Reply with quote

Guest

OK, not the answer I was hoping for, but thank you for your assistance.
I've moved to trying other programs. WS_FTP and FileZilla both appear to work - they both showed the $ in the file name, and allowed me to rename the file. And with the file transfer, the name did not get the $ inserted.

Reply with quote

Advertisement

You can post new topics in this forum