Opening Files in External Editor causes file group to change

Advertisement

jessebtmn
Joined:
Posts:
4

Opening Files in External Editor causes file group to change

When I save changes to files using the internal editor, the group stays the same (desired behavior). However, I have saved the same files from the external editors Atom and Visual Studio Code and in both cases the group changed from 'mydevgroup' to 'myusername' meaning I have to be careful not to lock other devs out of files that I'm editing. Is this something I can configure in WinSCP?

WinSCP: Version 5.17.5 (Build 10414)
Windows 10 Pro: Version 10.0.18363

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Re: Opening Files in External Editor causes file group to change

Please attach full session log files for both scenarios.

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

jessebtmn
Joined:
Posts:
4

Re: Opening Files in External Editor causes file group to change

Thanks for taking out the time to look at this. Here are my logs with redactions.
Description: This is me editing and saving file2.pl via the internal editor. The group stays as "devgroup".
Description: This is me editing and saving file2.pl via an external editor. The group changes from "devgroup" to "username1".

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Re: Opening Files in External Editor causes file group to change

The file is over 100 KB. With the default settings, such file is transferred via a temporary file, what causes the overship change:
https://winscp.net/eng/docs/resume#automatic
You can turn that feature off.
https://winscp.net/eng/docs/ui_pref_resume

The reason, why it's different in the internal editor, is that the internal editor forces a use of text transfer mode. With the mode, the transfer via the temporary file is never used. So as another solution, you can force the text mode for your external editor.
https://winscp.net/eng/docs/ui_editor_preferences

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum