WinSCP not responding when accessing folder with no name

Advertisement

Willem
Joined:
Posts:
5

WinSCP not responding when accessing folder with no name

When we access SFTP using WinSCP and access a folder which has a subfolder that appears to have no name, WinSCP freezes and needs to be closed through the Task Manager. Also the dates look to be incorrect in WinSCP. See attached screenshots.

Version 5.17.6 (Build 10516)

Thanks for your help.

Last edited by Willem on 2020-08-19 15:05; edited 1 time in total

Description: When we access the same FTP folder in a browser we get an error but can continue browsing in FTP

WinSCP - 1.jpg

Description: When we access the same FTP folder in WinSCP the application hangs. Also the dates look really strange (but that's not really relevant).

WinSCP - 2.jpg

Reply with quote

Advertisement

Willem
Joined:
Posts:
5

Just to be clear, when the specific files / folders without name are removed the issue no longer occurs. We have tested this, so it's definately a WinSCP issue. I'm just wondering why this causes WinSCP to crash and not just show an error like the webbrowser does.

Thanks very much,
Willem

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
34,115
Location:
Prague, Czechia

Re: WinSCP not responding when accessing folder with no name

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Guest

Re: WinSCP not responding when accessing folder with no name

Hi Martin, have you been able to have a look at the log file? Any ideas what's going on?

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: WinSCP not responding when accessing folder with no name

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Willem
Joined:
Posts:
5

Thank you Martin. For some reason the emails ended up in my Junk Folder. I will use the debug version and take note of the debug instructions.

Thanks again and have a good weekend.

Kind regards,
Willem

Reply with quote

Willem
Joined:
Posts:
5

Hello Martin.

Our FTP admins have resolved the issue on Friday so I was not able to run WinSCP debug version while the problem existed. They reported the FTP job would create an "Archive" folder with a leading "space" in it (" Archive"). This caused WinSCP to hang. Hope this helps and thanks for your time.

Kind regards,
Willem

Reply with quote

Advertisement

You can post new topics in this forum