Tip when copying files to OpenVMS

Advertisement

KZ
Joined:
Posts:
2

Tip when copying files to OpenVMS

Using version 5.18.4 RC (Build 11387) and copying (Ctrl+K) a file from Windows 10 to
an OpenVMS session, the destination offered by WinSCP may look like this:

Upload file FILE.TXT to remote directory:
/DKA300:[L.BLISS]/*.*

This fails. After a lot of experimenting, I found that the only formats that work are when I edit the above to:

/DKA300:/L/BLISS/*.*
/DKA300:/L/BLISS/

Trying /DKA300:[L.BLISS]*.* also works (second / removed), but does not copy the entire
name, just the extension, .TXT;1, for example. Playing with *, *.*.*, *.*;* and similar does not help.

I know that OpenVMS is not a high priority, so I'm happy to fix the above line manually,
but it would be nice for WinSCP to do the above automatically.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
35,731
Location:
Prague, Czechia

Re: Tip when copying files to OpenVMS

Please post a full session log file of an upload both with the default path and with your fix.

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

You can post new topics in this forum