Got an error with RC version

Advertisement

Advertisement

jmar83
jmar83 avatar

Yes, i can confirm that it works again when i downgrade to release version 5.17.10

P.S.: Where can i get the portable .zip for release version 5.17.10? I can only find the release candidate version ("RC") there.
_________________
With best regards,
Jan

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
36,052
Location:
Prague, Czechia

Re: Got an error with RC version

Please post session log files both from the 5.17.10 and the 5.18.5. Thanks.

Reply with quote

Advertisement

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

Now i saw it on: https://winscp.net/eng/docs/ui_pref_logging

-> I can't reproduce it anymore, seems to be gone with new WinSCP-5.18.5.RC-Portable version; the last version i tried was WinSCP-5.18.4.RC-Portable.zip last week.

So problem seems to be solved. Thank you very much!! :-)
_________________
With best regards,
Jan

Reply with quote

martin
Site Admin
martin avatar

There was no change in 5.18.5 that might have made it working. Something must have changed on the server or in your network.

Reply with quote

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

Hello Martin

Yes, you are right... it occured again!! :-(

Sometime it happens, sometime not.

What i've seen: It especially occurs when the file in the remote location (server) already exists - but not in every case.

Will look about if when i have the time. Thanks.
_________________
With best regards,
Jan

Reply with quote

Advertisement

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

OK - so i saw, the debug logs (also with Debug Level II) don't contain any passwords. So i post them here as a a file attachment called "WinSCP_logs.zip"...

Hope that helps. I there are any questions, so please don't hesitate to ask me for more informations regarding that issue. Thank you very much.
_________________
With best regards,
Jan
  • WinSCP_logs.zip (59.6 KB, Private file)
Description: This are the logs and some screenshots...

Reply with quote

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

Here
_________________
With best regards,
Jan
  • WinSCP Logs_5.1.7.zip (17.95 KB, Private file)
Description: here is v 5.1.7 log

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
36,052
Location:
Prague, Czechia

In WinSCP_logs.zip, the error occurs when overwriting a remote file. Is that always the case? Or do you get the error even when uploading a file that does not exist on the server yet? I do not see an equivalent operation in WinSCP Logs_5.1.7.zip (there's only an upload of a file that does not exist on the server yet).
Can you post two complete logs from those two versions showing the exactly same operation (same source file, same destination file, same state/contents of the remote folder), when it fails in the new version, but succeeds in the old one?

Reply with quote

Advertisement

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

"the error occurs when overwriting a remote file. Is that always the case?"

Yes, when i saw it right...


With kind regards, Jan
_________________
With best regards,
Jan

Reply with quote

martin
Site Admin
martin avatar

And does it happen every time you try to overwrite a file with the RC version? And never when you overwrite a file with the old version?

Reply with quote

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

And does it happen every time you try to overwrite a file with the RC version?"
Yes, 100% true!! Sometime it happens, sometime not - that's a fact.

And never when you overwrite a file with the old version?"
At least not with release version 5.1.7...

Reply with quote

martin
Site Admin
martin avatar

So please post:
1) Complete log file from the RC version that shows enough uploads of the same file over and over again (overwriting an existing remote file), so that at least two such transfers fail.
2) Complete log file from 5.1.7 showing the same number of uploads in the identical setup.

Reply with quote

Advertisement

jmar83
jmar83 avatar

Oh i forgot because i've gone back to the stable version. Will look on it ASAP. (Have a lot of things to do currently)
_________________
With best regards,
Jan

Reply with quote

Advertisement

You can post new topics in this forum