Ignore permission error seems not working

Advertisement

lucamosca
Joined:
Posts:
3
Location:
Italy

Ignore permission error seems not working

Environment: WinSCP 5.17.10 running on windows 10

We use WinSCP to have more users working on a shared directory on a Linux server. All users belong to the same Linux group but we need to set WinSCP set rwxrwx--- permissions to a new file copied on server so that another user of the same group can work on it.
If an other user try to overwrite the same file I have the usual 'operation not permitted error' even if I have the ignore permission error checkbox enabled.
In any case the file is correctly overwritten but, after try a lot of solution found here and there I start to suspect the Ignore ... is ignored.

Available to send additional info and logs (if someone tells me where to find it)

Luca

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,045
Location:
Prague, Czechia

Re: Ignore permission error seems not working

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

lucamosca
Joined:
Posts:
3
Location:
Italy

Unfortunately turn off set permission will be an issue due to server configuration (umask). Any chance to have it working also with scp protocol?
Asking just in case...

Thanks

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,045
Location:
Prague, Czechia

I do not follow. If you need to set the file permissions, why are you trying to set "Ignore permission errors"?

Your server does not seem to be able to set file permissions. If you need to set the permissions, you need to fix your server. No settings on WinSCP side can fix that. Or are you able to set the permissions using any other SCP client?

Reply with quote

Advertisement

You can post new topics in this forum