WinSCP (current stable) does not show symlinks

Advertisement

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

WinSCP (current stable) does not show symlinks

I created it on httpdocs folder on SSH console. WinSCP does not show. But when I upload a file with WinSCP and then make ls in that httpdocs dir, then I will see both.

How to make WinSCP show symlinks?

Thx for feedbacks!!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,052
Location:
Prague, Czechia

Re: WinSCP (current stable) does not show symlinks

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

jmar83
jmar83 avatar
Joined:
Posts:
47
Location:
Switzerland

Hi Martin

Thank you very much for your feedback. Firstly, i was thinking that it is an option similar to the "Show hidden files" (e.g. ´.htaccess´) - but, at least so it seems, it is not.

Logs (and also screenshots) are attached and flagged as "private" - so just for you...
_________________
With best regards,
Jan
  • WinSCP Logs - symlink problem.zip (115.45 KB, Private file)
Description: logs & screenshots

Reply with quote

martin
Site Admin
martin avatar

The log shows only .well-known file in the folder. Which I do not see in your terminal screenshot. Can you explain? On the other hand, can you see the symlink using any other FTP client? Try setting "Use MLSD command for directory listing" to Off.

Reply with quote

jmar83
jmar83 avatar

At least, i see the symlink in the SSH console - in fact, it exists. Now i will look with that MLSD thing...
_________________
With best regards,
Jan

Reply with quote

Advertisement

jmar83
jmar83 avatar

Yes, when i set that MLSD thing to "off", i see it. (With a symlink icon, with arrow...)

Question: Is that a feature or a bug...? ;-)
_________________
With best regards,
Jan

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum