Odd "This program requires Windows Service Pack 1 or later." error - upgrading from 5.17.10 to 5.19.

Advertisement

LTI
Guest

Odd "This program requires Windows Service Pack 1 or later." error - upgrading from 5.17.10 to 5.19.

While trying to install the current 5.19 setup file from my current 5.17.10 (Build 11087), I get the error in the title, with the only option to close the warning modal. Service Pack 1 is very much installed on this machine, and no previous WinSCP setup file has triggered a complaint.

Please advise.

Reply with quote

Advertisement

Ray
Joined:
Posts:
11
Location:
Earth for sale: Slightly Used: Inquire within

Windows 7 Ultimate - Version 6.1 (Build 7601)

According to the "Programs and Features" applet, SP1 was installed at the tail end of 2012

Reply with quote

Advertisement

Ray
Joined:
Posts:
11
Location:
Earth for sale: Slightly Used: Inquire within

2021-06-24 12:17:35.637   Log opened. (Time zone: UTC-04:00)
2021-06-24 12:17:35.637   Setup version: Inno Setup version 6.2.0
2021-06-24 12:17:35.637   Original Setup EXE: F:\WinSCP-5.19-Setup.exe
2021-06-24 12:17:35.637   Setup command line: /SL5="$45400A,10288217,864256,F:\WinSCP-5.19-Setup.exe" /LOG="winscp.log"
2021-06-24 12:17:35.637   Windows version: 6.1.7601  (NT platform: Yes)
2021-06-24 12:17:35.637   64-bit Windows: Yes
2021-06-24 12:17:35.637   Processor architecture: x64
2021-06-24 12:17:35.637   User privileges: Administrative
2021-06-24 12:17:35.645   Administrative install mode: Yes
2021-06-24 12:17:35.645   Install mode root key: HKEY_LOCAL_MACHINE
2021-06-24 12:17:35.645   64-bit install mode: No
2021-06-24 12:17:35.645   Message box (OK):
                          This program requires Windows Service Pack 1 or later.
2021-06-24 12:17:37.554   User chose OK.
2021-06-24 12:17:37.554   Got EAbort exception.
2021-06-24 12:17:37.554   Deinitializing Setup.
2021-06-24 12:17:37.555   Log closed.

Description: SP-1 is installed

SP-1.jpg

Reply with quote

Advertisement

Ray
Joined:
Posts:
11
Location:
Earth for sale: Slightly Used: Inquire within

Very odd. Even as a long-time IT guy (since 1983), I have no explanation for why mine doesn't include that on this page.

I intend to upgrade to Win 10 sometime in the semi-near future, so it's not exactly critical that I get WinSCP updated immediately. Still, I am now extremely curious to learn why my install shows my installation of SP-1 back in 2012 (KB976932) in the WU screen (but not on that page), while your installer is unable to confirm SP-1 on the system. Does your WU screen show the date & WU number of your upgrade to SP-1? If they are the same KB number, then I'm stumped, but also stuck at an outdated version of WinSCP.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
36,025
Location:
Prague, Czechia

I have it listed as:
Windows 7 Service Pack 1 for x64-based Systems (KB976932)
Though note that my Windows 7 system was installed in 2014, so after the SP1 was released.

Reply with quote

Advertisement

You can post new topics in this forum