Root folder not showing up

Advertisement

TervisK
Guest

Root folder not showing up

Hello folks.

Having an issue regarding folders showing up in Windows Server 2008 R2

When connecting to the FTP server, I am able to connect fine but no remote folders show up at all. The directory is listed as /<root> when it should be "Shared" by default. When I use the same login credentials on my Windows 10 machine, all the folders show up as they should. Any ideas?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,177
Location:
Prague, Czechia

Re: Root folder not showing up

Please attach session logs from both machines.

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
chines.

Reply with quote

TervisK
Guest

Re: Root folder not showing up

Hi Martin,

Attached are the logs. Wasn't sure if you needed the text or XML so I included both. The ones labelled KESR are from my machine which is working as it should. The ones labelled Egnyte are from my clients machine which is having the issues.

Thanks for your help!

Reply with quote

Advertisement

TervisK
Guest

Re: Root folder not showing up

Hi Martin,

I think I changed that while trying to troubleshoot. I am indeed able to get into the root folder and then navigate to the shared. I've attached new KESR logs to reflect that.

We tried changing the login directory on the other machine to /Shared as well, and it would login no problem, but none of the folders that should have been there showed up at all.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
38,177
Location:
Prague, Czechia

Re: Root folder not showing up

Well, the log shows that the server returned an empty directory listing.

There's still one difference though. In "Egnyte" session, you are using explicit TLS encryption. While in "KERS-Egnyte" session, you are using implicit. It shouldn't matter, but try to align it anyway.

Post new pair of logs with the same settings, if it does not help.

Reply with quote

TervisK
Guest

Alright so switched up to to Implicit encryption and still same issues. Log attached.

Now oddly enough, we tried SFTP and everything showed up as it should.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,177
Location:
Prague, Czechia

There's still one difference. The logs show different certificates:
Egnite:
. Verifying certificate for "Egnyte, Inc." with fingerprint 01:a8:4e:23:ff:6a:a1:ea:ee:fc:cc:ba:08:58:b1:ad:bd:6b:c5:fc:fd:0d:45:ce:75:c6:b0:ef:16:b7:ec:fe and 19 failures
KERS-Egnyte:
. Verifying certificate for "Egnyte, Inc." with fingerprint 34:5c:06:02:88:eb:ef:32:41:25:ab:7e:81:b2:fc:f4:4d:ee:8e:6f:b5:84:8b:e0:71:61:65:a0:76:85:7a:b9 and 20 failures
But the certificates are consistent between the two "Egnyte" and the two "KERS-Egnyte" logs. So it's not like the certificate is volatile. It seems like you are not actually connecting to the same server with the Windows 10 and 2012 machines. Please check with your network administrator.

Reply with quote

TervisK
Guest

Root folder not showing up

Sorry for the late response.

That is very strange. I think we are good to go now. Oddly enough, when we tried to connect via SFTP instead, everything worked as it should...strange.

Thanks for all your help Martin!

Reply with quote

Advertisement

You can post new topics in this forum