Wrong file time for some files

Advertisement

denaz77
Joined:
Posts:
3

Wrong file time for some files

Hi, I don't know why, but for some transferred file from local to remote, either manually and by sync script, the file time changes, and some other times the seconds are added, but most of the times not. The strange fact is that this happens only for some file, really few, and working with synchronization by date and size, this means that some file are always transferred.
I've added a screenshot, so you can see this, and as you can see, it happens only for few files (every time the same files).

Thanks

Immagine 2022-04-01 105350.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,209
Location:
Prague, Czechia

Re: Wrong file time for some files

Please attach a full session log file showing the problem (using the latest version of WinSCP). Give us a name of one file for each behavior.

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

denaz77
Joined:
Posts:
3

Hi, here you have the log. Those are the file that are syncd everytime i launch the script (every hour).
EW0240_2.jpg
EW0254_1.jpg
EW0254_2.jpg
EW0255_1.jpg
EW0255_2.jpg
EW0256_1.jpg
EW0256_2.jpg
EW0505_1.jpg
EW0505_2.jpg
EW0559_2.jpg
EW0560_2.jpg
EW0561_1.jpg
EW0561_2.jpg
EW0562_1.jpg
EW0562_2.jpg
EW0570_2.jpg
EW0571_2.jpg
EW0572_2.jpg
TJ3159.jpg
TW1942_1.jpg
TW1942_2.jpg
TW1943_1.jpg
TW1943_2.jpg
TW1944_1.jpg
TW1944_2.jpg
TW1945_1.jpg
TW1945_2.jpg
TW1946_1.jpg
TW1946_2.jpg
TW1947_1.jpg
TW1947_2.jpg
TW1948_1.jpg
TW1948_2.jpg
TW1949_1.jpg
TW1949_2.jpg
TW1950_1.jpg
TW1950_2.jpg
  • log.txt (1.02 MB, Private file)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
38,209
Location:
Prague, Czechia

Re: Wrong file time for some files

Thanks. Though I was asking for "one file for each behavior". You gave me loads of names, presumably for the "Wrong file time" behavior only.

Though actually I do not see same behavior for these. Randomly picking EW0240_2.jpg and TW1943_2.jpg, the first is not synchronized while the latter is.

Taking a look in more details at the synchronization of TW1943_2.jpg: Imo, WinSCP behaves correctly. To debug this further, I'd probably need a log for the consecutive synchronization. In which, if I understand the problem correctly, the file is synchronized again, despite being synchronized before already.

Reply with quote

denaz77
Joined:
Posts:
3

Hi and thanks.
I've repeated 2 times the sync with only the file TW1943_2.jpg in the mask, and it has been syncd both times. You can find the two logs attached, i've cleaned everyting in them but the rows related to TW1943_2.jpg.
I hope it can be useful.
  • log_1420.txt (8.97 KB, Private file)
  • log_1418.txt (9.22 KB, Private file)

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Thanks. Though can you post full logs? Or even better, logs showing a synchronization of folders that contain only that one file.

Reply with quote

Advertisement

You can post new topics in this forum