Suppress Network Error Popup upon losing connection

Advertisement

abhijita07@gmail.com
Donor
Joined:
Posts:
3

Suppress Network Error Popup upon losing connection

I have been using WinSCP for over 12 years now. Always wondered how to suppress the Network Error screen pop-up after losing the connection or when VPN connection timed out or if PC sleeps or hibernates while the connection was still on and throws error popup as soon as it wakes up.

Is there a way, that WinSCP remote window itself is greyed out to show the loss of connection with an option to reconnect, but no Network Error popup on screen? This would be a feature addition, if not already. Let the User chose whether they want a Greyed-out remote window or a Network Error popup.

This popup is causing my PC screen to freeze upon wake up. And if I switch between my monitor and laptop screens, this popup makes WinSCP unresponsive that I have no choice but to terminate it and restart. Also, the font-size on WinSCP suddenly becomes unreadable while switching between screens. That's another issue. Could someone please respond if that is even feasible what I am asking for? Or if it's already there somewhere and I'm not aware of it?

Thank you.

Description: Network Error Popup screenshot

WinSCP-Screenshot 200349.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,984
Location:
Prague, Czechia

Re: Suppress Network Error Popup upon losing connection

So what is the problem? The popup or the freeze? I do not think that removing the popup would solve the freeze. If you want to try helping me solving the freeze, I'm sending you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

diox8tony
Guest

Too many popups warnings

When I have an open connection, then unplug the device. WinSCP responds by popping up 3-5 various windows that I must click through to close the program. "warning connection lost" OK, "Reconnect?" NO, "something went wrong", OK....just let me close you!

Sorry I did not spend the time screen capturing the various pop up warnings. It seems like each time I do it there is a random assortment of different warnings.

It would be nice to simplified this process. The first dialog should have the option to "close program".

Reply with quote

abhijita07@gmail.com
Donor
Joined:
Posts:
3

I know this is old, but somehow never resolved. This is what I am facing. The main problem is the Connection Error (Reconnect) popup and NOT the freeze. In fact, the popup is causing the screen freeze.

When I have an active connection open in WinSCP and I put my PC to sleep, after it wakes up the Connection Error popup seems to either freeze the screen and other windows from opening or just shows nothing in popup (see attached screenshot) or both. This gets even more annoying when moving between laptop screen and external monitor. This popup just stops everything from moving to second monitor until either the connection is restored or WinSCP window is closed/terminated. With the white (blank) popup (as attached), I have to kill the process from Task manager. Simply closing the window doesn't work.

All I am looking for is a way to disable or suppress this Connection Error popup on screen, with an option to restart the connection (Reconnect) in the WinSCP Main Panel window or leave it alone. I would appreciate any help on this.

Description: WinSCP White (blank) popup, with no option to click or close

winscp-white-popup.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar

@abhijita07: Ok, but that seems different to what you were reporting before.

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum