WinSCP stuck at authenticating

Advertisement

aditya.kumar
Joined:
Posts:
1
Location:
India

WinSCP stuck at authenticating

We are scheduling some bat scripts via Task Scheduler so that we can download and upload files from and to an SFTP server. Sometimes the WinSCP gets stuck in authenticating. We have not specified any log file when running the WinSCP.com file. We also faced the same issue when we tried to run the WinSCP GUI.
We are using WinSCP version: 5.19.5

attach.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
37,591
Location:
Prague, Czechia

Re: WinSCP stuck at authenticating

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Can you successfully connect to the same server using the same protocol from the same local machine using any other client?

Reply with quote

xblackbird91
Joined:
Posts:
1

Permission denied

Hi guys, I need your help. I have been using WinSCP normally, but for some reason yesterday I have used a command netcfg -d in my Windows PowerShell. After that I cannot login remotely to my Ubuntu, when I am trying to access, it says permission denied to login.
p.s: same problem with PuTTY also.

Reply with quote

Guest

Ubuntu 22.04 and WinSCP

Ubuntu 22.04 SSH the RSA key isn't working since upgrading from 20.04

There are issues using WinSCP (and even PuTTY) after upgrading to or using 22.04. With PuTTY, you can just make sure you are on the latest (0.77). For WinSCP (from the link above):
If you don't want to use a new key, and want to re-enable RSA, edit the file /etc/ssh/ssh_config and add this line:
PubkeyAcceptedKeyTypes +ssh-rsa
This will allow the use of unsafe RSA key you already have.

Here is the bug report: Bug 1952 – Support rsa-sha2-256 and rsa-sha2-512 SSH public key algorithms
and info from the bug report:
OpenSSH 8.8 disabled ssh-rsa by default. Until WinSCP 5.20 is released, add this to server's sshd_config to re-enable it:
PubkeyAcceptedAlgorithms +ssh-rsa

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum