'Could not retrieve directory listing' on FTP with explicit TLS

Advertisement

ceztko
Joined:
Posts:
3

'Could not retrieve directory listing' on FTP with explicit TLS

Hello, I am trying to connect to a FTPS service with explicit TLS configured, and it does timeout with the following error:
Timeout detected. (control connection)
Could not retrieve directory listing
Error listing directory
The connection to the same host with FileZilla works correctly and it's instant. I'm attaching the log for the connection (I edited slightly to remove some host/user information). I'm having the issue with WinSCP 5.21.7 stable and also 6.0.1 beta (log taken with 5.21.7, I can repeat it with 6.0.1 if requested). I also followed this guide to no avail:
Why is WinSCP not able to connect to a server, when other clients are?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,278
Location:
Prague, Czechia

Re: 'Could not retrieve directory listing' on FTP with explicit TLS

I assume the 0,0,0,0 is your edit, right? That's the most important part of the log in respect to your problem. It is hard to help when you hide it. Was the original IP address correct? Post also FileZilla log file too.

Reply with quote

ceztko

Re: 'Could not retrieve directory listing' on FTP with explicit TLS

Actually not! I didn't edited that 0.0.0.0, I just removed the hostname, the user and the folder. I will send to your email the non-edited logs.

Reply with quote

ceztko

Re: 'Could not retrieve directory listing' on FTP with explicit TLS

Thank you! I tried several options but I missed that. I will definitely point this to my IT department, that is directly handling that server. Maybe also WinSCP can learn how to auto workaround this situation similarly to FileZilla?

Reply with quote

Advertisement

You can post new topics in this forum