UNBLOCK didn't work for HRESULT: 0x80131515

Advertisement

derrrek
Joined:
Posts:
2

UNBLOCK didn't work for HRESULT: 0x80131515

Good day everyone,

I am experiencing this issue:
Could not load file or assembly ‘file:///…\WinSCPnet.dll’ or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)
The page on this site shows us to UNBLOCK the file and it should work:
https://winscp.net/eng/docs/message_net_operation_not_supported

However, UNBLOCK doesn't work, we keep getting the same error over and over again.

I have unblocked the installation file and then installed, I have then unblocked the folder where it was installed and still no go.

Any other suggestions?

NOTE: We are experiencing the above error only on a Windows Server 2019 machine - when we run the transfer script from a Win 10 machine, everything works, no errors come up and the transfer completes.

Both instances are being run by a user who is a part of the admin group, site admin group, ad/dc admin .... when its run from the same mapped drive it works from the Win10 machine but not from the Win Server 2019 machine. - We even tried running with a local server admin account.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,837
Location:
Prague, Czechia

Re: UNBLOCK didn't work for HRESULT: 0x80131515

What installation file or folder did you unblock? You should unblock the WinSCPnet.dll file.

Reply with quote

derrrek
Joined:
Posts:
2

Re: UNBLOCK didn't work for HRESULT: 0x80131515

We packed up winscp.exe, the .dll and our script, into one executable file (our exe simply unpacks – nothing special about it). After downloading our EXE from our Google Drive, I right click and go to Properties and unblock it. I then paste it into the folder where it needs to be. I run it, extract and usually overwrite (there are older versions of the the script and dll).

I then run the UNBLOCK command for the whole parent folder – that unblocks every sub folder and file in that folder.

This is the command I run
Get-ChildItem "Z:\BRO" | Unblock-File
Do you think I should run the cmdlet just on the dll?

Reply with quote

martin
Site Admin
martin avatar

Re: UNBLOCK didn't work for HRESULT: 0x80131515

Are you able to make the DLL work on that machine, if you just download our Automation package and extract it (and unblock it)?

Reply with quote

Advertisement

You can post new topics in this forum