Put *.xls Also Uploads .xlsM File

Advertisement

Robot_1X
Joined:
Posts:
3

Put *.xls Also Uploads .xlsM File

put "C:\Users\OSVAdmin\Documents\OSV Template\"*.xls /
This line uploads my .xls files just fine, but it also uploads the .xlsm file that resides in the OSV Template folder. Unfortunately, I cannot just move the .xlsm file to a different folder because an Excel spreadsheet I use for work needs it in this folder.

Does anyone have any suggestions on how I can prevent the .xlsm file from being uploaded?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,866
Location:
Prague, Czechia

Re: Put *.xls Also Uploads .xlsM File

I cannot reproduce the problem.

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,866
Location:
Prague, Czechia

Strange. I've tried the same command as you with the same files, and only xls files are transferred.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include a link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,866
Location:
Prague, Czechia

Ok, so I've found that on other drive, I get the same behavior as you. It turned out that there's a volume setting that affects this.
See Windows wildcards with files having more than 3 characters extensions
(I've posted my own answer there too).

So either change the volume settings.
Or you can fix it by using a file mask filter:
put -filemask=*.xls "C:\Users\OSVAdmin\Documents\OSV Template\*" /
The filemask in -filemask is evaluated by WinSCP, what is independent to the volume settings. While the mask in the source parameter is evaluated by the Windows, what is affected by the volume settings.

Reply with quote

Advertisement

You can post new topics in this forum