Error transferring a file when it contains the character "–".

Advertisement

rrdein
Joined:
Posts:
1
Location:
USA

Error transferring a file when it contains the character "–".

I was transferring some files and 2 files would not transfer. The error was "No such file or directory" which of course made no sense. I noticed the two files had a hyphen that was different from other hyphens. The character was . I don't need a resolution but I'm reporting it so that it can be fixed, if so desired. My OS (Windows) didn't reject that character, so my FTP client (I was using FTP specifically) also should not reject it, in my view, so I feel that this is a bug which should be corrected. I have seen other report the same error with no resolution, so perhaps non-ASCII characters are the cause.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,567
Location:
Prague, Czechia

Re: Error transferring a file when it contains the character "–".

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

You can post new topics in this forum