Topic "automatically reconnect when connection is dropped?"

Author Message
anthony

Guest


When a temporary network problem occurs, and I get a message like this from WinSCP:

Code:

Network error: Connection reset by peer
[ OK ]  [ Reconnect ]


...can you add a feature so that WinSCP automatically reconnects, so I don't have to press the button, and so the dialog is never even displayed?

Thanks.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
This should happen automatically during file transfers. Doed it?
_________________
Martin Prikryl
anthony

Guest


Yes, it happens during file transfers, but I'm not talking about that. I'm talking about when you're not transferring a file, and the connection gets cut off for some reason. You get a dialog that asks whether you want to reconnect. There should be an option that lets me say "always reconnect, never ask me".
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
anthony wrote:
Yes, it happens during file transfers, but I'm not talking about that. I'm talking about when you're not transferring a file, and the connection gets cut off for some reason. You get a dialog that asks whether you want to reconnect. There should be an option that lets me say "always reconnect, never ask me".

Can be. But I do not see much advantage of it.
_________________
Martin Prikryl
Anthony

Guest


Are you kidding?? If you're on a connection that is somewhat unstable -- like some wireless connections, which many people use, or a connection to a server whose network link is very busy -- you sometimes get cut off every 5 minutes. It's only a very temporary problem, but because WinSCP fails to auto-reconnect, it is extremely annoying, since you need to stop what you're doing and switch to the WinSCP window and hit the reconnect button.

Having an auto-reconnect option would be extremely advantageous. It's exactly like the auto-resume when the connection gets dropped in the middle of a transfer. Why would you say that auto-reconnect is advantageous during one operation but not another??
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Quote:
Having an auto-reconnect option would be extremely advantageous. It's exactly like the auto-resume when the connection gets dropped in the middle of a transfer. Why would you say that auto-reconnect is advantageous during one operation but not another??

I've meant that I do not see a big advantage of autoreconnect, when WinSCP is idle. Then there's no point to reconnect it every time the connection drops. You need to reconnect it only once you finally needs to use it. Do I miss something?
_________________
Martin Prikryl
Guest




Yes, you are missing what I'm saying. It is annoying and inconvenient to have to manually press a "Reconnect" button, regardless of whether WinSCP is idle or not. When I'm connected to a server with WinSCP, I want the connection to be alive the whole time; otherwise I would just use a command-line SCP client.
n00ge

Guest


I think the main reason why so many people ask for the "auto-reconnect" option is because when it disconnects it is very distracting. When an alert window is up, people feel the need to respond to it immediately. That is very distracting for me.

If it is a hassle or doesn't make sense to auto-reconnect, what about changing the way the user sees it. Maybe make it more subtle like making the folder/file names greyed out and reconnect if the user tries to open a folder or transfer a file?
Eddy

Guest


I have the same issue and it IS annoying, especially when you are working outside WinSCP.
I would like to suggest a couple of options:
- Lose the Alert box (leave the rest as is, graying out the remote side as n00ge suggests would be great). I would gladly reconnect on my own convenience (trust me Alert boxes ARE annoying).
or
- Kill the Idle mode (send a ftp command or whatever) every X seconds (this in combination with different sftp accounts so a user can chose if he/she wants this option on/off, just like auto resume transfer thingie)
or
- On Network error: Connection reset by peer (when Idle) automatically reconnect (in combination with sftp accounts above).
Guest




I wonder how anyone can stand winscp with its annoying reconnect (using an unstable wifi connection)
Josh

Guest


Eddy wrote:
I have the same issue and it IS annoying, especially when you are working outside WinSCP.
I would like to suggest a couple of options:
- Lose the Alert box (leave the rest as is, graying out the remote side as n00ge suggests would be great). I would gladly reconnect on my own convenience (trust me Alert boxes ARE annoying).
or
- Kill the Idle mode (send a ftp command or whatever) every X seconds (this in combination with different sftp accounts so a user can chose if he/she wants this option on/off, just like auto resume transfer thingie)
or
- On Network error: Connection reset by peer (when Idle) automatically reconnect (in combination with sftp accounts above).


These are all good ideas. The bottom line is, it *is* very inconvenient to have that alert box popping up all the time when there is a connection lost, for whatever reason. I think the first idea is the best -- use UI cues to indicate that the connection has been lost, and automatically reconnect as soon as the user tries to do anything (e.g., refresh, change working directory, etc.).

-Josh
heeen

Guest


I'd like to second this request. If you're working on files in an external editor and the connection gets dropped and you try to save the file, winscp should not ask you to reconnect, it already knows you have a file open and you want it to be updated to the server. Also, if you change several files you have opened remotely, all saves to files subsequent to the first one (which failed due to a dropped connection) will also fail, you change to your putty session and wonder why your changes didn't work. so you have to tell winscp to reconnect, do some dummy change like adding a newline and removing it to ALL failed transfers, save the files, so winscp recognizes the change, and only then it will upload the files.
VERY annoying. Please add a feature to reconnect without asking, if not immediately when the connection drops, at least the next time you require a connection.
heeen

Guest


The same thing applies to browsing directories after the connection dropped. Winscp already knows I want to read this directory, why should it ask me if I really want to reconnect?
This feature would be very appreciated Smile
allwebnow
[View user's profile]

Joined: 2007-03-28
Posts: 4
Location: ohio
Yes, I would like to request this as well. It is very disrupting to have that network error dialog box keep popping up frequently when idle.
Fat

Guest


I have big problems without auto-reconnect option, because I have 128kbit ADSL line & I need upload to server big files. I begin uploading files when go to sleep & when i awakening, I often see this error Evil or Very Mad and 90% of not uploaded files, it's no good.

P.S. Sorry for bad english,i'm russian )))
Fat

Guest


I try beta version, it's more stable for me, because 15 hours of uploading & no stop with this error.
allwebnow
[View user's profile]

Joined: 2007-03-28
Posts: 4
Location: ohio
Any word on how this feature is coming along?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
allwebnow wrote:
Any word on how this feature is coming along?

This is quite complex task, so there are no estimates on its completion yet.
_________________
Martin Prikryl
allwebnow
[View user's profile]

Joined: 2007-03-28
Posts: 4
Location: ohio
Couldn't you just create an option to auto reconnect instead of having that network error message pop up awaiting a response..ie. (check here to not show this message again)? and then In the event that the user has this setting set and he truly does lose connectivity and auto reconnect fails after x amount of times, winscp would simply stop trying to reconnect and then the appropriate network error pop up message would then appear. Because, for me winscp always times out even though my computer doesn't really lose full connectivity on the network but winscp thinks it does i guess.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
allwebnow wrote:
Couldn't you just create an option to auto reconnect instead of having that network error message pop up awaiting a response..ie. (check here to not show this message again)? and then In the event that the user has this setting set and he truly does lose connectivity and auto reconnect fails after x amount of times, winscp would simply stop trying to reconnect and then the appropriate network error pop up message would then appear. Because, for me winscp always times out even though my computer doesn't really lose full connectivity on the network but winscp thinks it does i guess.

Yes that would be feasible.
_________________
Martin Prikryl
allwebnow
[View user's profile]

Joined: 2007-03-28
Posts: 4
Location: ohio
Oh, that would be great! Do you have an ETA for something like this to be implemented?
simplistik

Guest


Yea this would be a great feature. I find that WinSCP is probably the best SFTP program I've used. Main features being opening multiple files off a server w/ one instance of the program. But when you have a crappy server (like one of the ones i work on) it times out all the time regardless of activity. So an auto reconnect feature would help greatly Smile
ilg

Guest


auto-reconnect would be especially helpful on FTP sessions--I have no trouble with my SFTP sessions staying alive, but my FTP sessions drop after about 5 minutes of idle time, if even that long, and if I try to save a file I've been editing while the reconnect box is up, then hit reconnect, it *always* corrupts the remote file.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
ilg wrote:
auto-reconnect would be especially helpful on FTP sessions--I have no trouble with my SFTP sessions staying alive, but my FTP sessions drop after about 5 minutes of idle time, if even that long, and if I try to save a file I've been editing while the reconnect box is up, then hit reconnect, it *always* corrupts the remote file.

What version of WinSCP are you using?
_________________
Martin Prikryl
ilg

Guest


prikryl wrote:
ilg wrote:
auto-reconnect would be especially helpful on FTP sessions--I have no trouble with my SFTP sessions staying alive, but my FTP sessions drop after about 5 minutes of idle time, if even that long, and if I try to save a file I've been editing while the reconnect box is up, then hit reconnect, it *always* corrupts the remote file.

What version of WinSCP are you using?


4.0.3 (Build 345)

I don't think the disconnecting is a WinSCP issue, but rather the server behaving badly (it's an ISP that doesn't implement SCP/SFTP, so I have no respect for them to begin with). It wouldn't surprise me if the corruption had to do with their FTP server, too.
undoIT

Guest


Many FTP clients have a "Keep Alive" option to prevent disconnections from happening or to automatically reconnect. I'd love to see this implemented on WinSCP.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
undoIT wrote:
Many FTP clients have a "Keep Alive" option to prevent disconnections from happening or to automatically reconnect. I'd love to see this implemented on WinSCP.

WinSCP have that too. See Connection tab on login dialog. In 4.0.3 it should be enabled by default.
_________________
Martin Prikryl
undoIT

Guest


Ah. There it is! I was looking under Options>Preferences. It was off by default on my install.
KAZVorpal
[View user's profile]

Joined: 2007-09-04
Posts: 2
Location: http://360.yahoo.com/kazvorpal
undoIT wrote:
Ah. There it is! I was looking under Options>Preferences. It was off by default on my install.


Off by default on mine, too.

For me, there is an extremely practical reason to be concerned with the disconnect popup...I am a web developer, and edit files remotely through winscp and ultraedit. When I'm editing a file for too long, winscp would lose the connection and pop up would occur. Then when I hit save in UltraEdit, the file does not get transferred to the ftp site.

This means I have to watch for the disconnect popup, then click reconnect, or else my changes mysteriously stop showing up on the website, until I realize what's gone wrong.
Rastaban

Guest


Very Happy Thanks, Great program and this just made it better!!!
Mammoth

Guest


prikryl wrote:
allwebnow wrote:
Couldn't you just create an option to auto reconnect instead of having that network error message pop up awaiting a response..ie. (check here to not show this message again)? and then In the event that the user has this setting set and he truly does lose connectivity and auto reconnect fails after x amount of times, winscp would simply stop trying to reconnect and then the appropriate network error pop up message would then appear. Because, for me winscp always times out even though my computer doesn't really lose full connectivity on the network but winscp thinks it does i guess.

Yes that would be feasible.


Yeah - I would like this feature too.
When is ETA ?
grzchr15

Guest


winscp thinks that the server disconnects but is can be only temporally.
Reconnect works again, why not automatic reconnect.

I tried various options of keep alive or auto reconnect.
winscp still thinks frequently the line dropped.

So please how can we get this reconnect if line dropped for a short moment.

Thanks for this nice programm.
Synchronise and compare would be so nice to used.
But i get "disconnect" during even compare dirs.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
grzchr15 wrote:
I am background copying a lare ftp set and i get frequent:

WinSCP should automatically reconnect when connection is dropped during file transfer. What version are you using?
_________________
Martin Prikryl
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
This issue has been added to tracker.
_________________
Martin Prikryl
Ron.IT

Guest


The dialog on disconnect with the "ok" or "reconnect" options is indeed a bad one to wake up to when you find out a background file transfer only worked for half an hour and has been sitting with that prompt the entire night.

I've seen many programs that offer simelair dialogs, but then they have a countdown timer go that if no other option is selected, that option is automatically selected.

Now I don't know how complex that would be in your program, but I can't believe it would be "that" complex compared to how the rest of the program functions.

So the dialog would be something like:

[OK] [Reconnect (30)]

Where the 30 seconds would count down and when it reaches 0 it will press that button. The 30 seconds can then be an option inside configuration or use the same value as the existing reconnect option (which I assume is for Foreground transfers).

The countdown animation could be optional if it's too much programming effort to do so.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Ron.IT wrote:
The dialog on disconnect with the "ok" or "reconnect" options is indeed a bad one to wake up to when you find out a background file transfer only worked for half an hour and has been sitting with that prompt the entire night.

What version of WinSCP are you using?
The prompt your are seeing is most probably for the main session and is not related to background transfer. The background transfer should continue despite the error. Maybe just the progress indicator is not being updated. But once you reconnect, the indicator should display current status.
_________________
Martin Prikryl
Ron.IT

Guest


Even tried again with latest 4.10beta to verify the problem wasn't fixed already (was using 3.8.2 before).

When I'm actually sitting ontop of it, the background transfer shows the information prompt icon flashing, where the error if viewed is something like "can not reach host for 15 seconds", only option is to abort which would then remove entry from background transfer, but if I wait, that one usually automatically goes away.

The weird thing is that all this time, I'm able to browse the actual server, and view directory listings not previously visited (to avoid cache conflict).

But it's ok, after finally being fed up with the short download times from WinSCP, I did a search on SourceForce to find that FileZilla also has PKI-SFTP support, and that one has been downloading without any problems for more then 20 hours now.

I'll keep an eye out for new versions on WinSCP, as I hope you will be able to fix the problem.
Ron.IT

Guest


Ohh and to eleborate on your question.

The background transfer indicator slowly lowers itself. I'm assuming that its based on total transfer amount over time, and not relative, because the rate at which it slows down doesn't correspond with the abrupt global datatransfer rate I monitor.

I'm using a Download/Upload monitor util and that one drops instantly to 0 when WinSCP errors. So the file is not being continued in the background as you suggest.
roger

Guest


Auto-reconnect would be very helpful. I have some customers who bring in drives with bad sectors and request as much data off the drive as possible. They don't care how long it takes, just get the data. So I hook the drive up in an external case, and winscp the data over to their server. Large amounts of data (i.e. several GB) can take days even over high speed so continually hitting the "reconnect" button gets extremely annoying. I just want it to slowly copy the data over and be done with it... damn, it just popped up again!!! SHEESH! Stupid "Network Error: Software caused connection abort" YES RECONNECT!!!! ARGH!
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
roger wrote:
Auto-reconnect would be very helpful. I have some customers who bring in drives with bad sectors and request as much data off the drive as possible. They don't care how long it takes, just get the data. So I hook the drive up in an external case, and winscp the data over to their server. Large amounts of data (i.e. several GB) can take days even over high speed so continually hitting the "reconnect" button gets extremely annoying. I just want it to slowly copy the data over and be done with it... damn, it just popped up again!!! SHEESH! Stupid "Network Error: Software caused connection abort" YES RECONNECT!!!! ARGH!

What version of WinSCP are you using? This should be fixed since 4.1.4.
_________________
Martin Prikryl
roger

Guest


4.0.7, I'll update it.

Thanks!
AMIGrAve
[View user's profile]

Joined: 2008-01-15
Posts: 2
Location: Belgium / Brussels
Yeah I confirm this issue is very annoying. As currently I'm mainly using ftp, I temporary switched back to Filezilla until this issue is resolved.

I don't know if there's a problem with Winscp or if Filezilla does silently autoreconnect, but I never had this issue with Filezilla.

On the other hand, with WinSCP, this disconnection dialog happens many times a day. Eg: I'm coding something in vim, then the dialog raises on top of everything and the focus has been given to that dialog, loosing what I was typing. This is really annoying.

When using WinSCP over VPN (very unstable connection) this dialog popups every 5 minutes, and during file transfer it can popup every 30 seconds ! Sometimes I have to reconnect 2 times when transfering a 500Ko file.
mktsui

Guest


Putty allows users to send a null byte to server every X seconds, this can be enable/disable somewhere in the settings.

Could that be a solution?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
mktsui wrote:
Putty allows users to send a null byte to server every X seconds, this can be enable/disable somewhere in the settings.

WinSCP does that too. Please read documentation.
_________________
Martin Prikryl
wl

Guest


I have the same problem with Winscp407 and 418 (both portable). I wonder if winscp is causing my wifi to drop during file copy. This happen every time I copy file from remote to local. It will try to reconnect but it asked me to input login information every time. Worst of all, my putty session was killed due to the lost of wifi. This does not happen to my wifi when I use other ftp clients. My wifi actually seldom disconnect. So any idea why Winscp will affect the wifi?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
There are too many unrelated issues being discussed in this topic.
Please start new topic with your issue (possibly linking back to this one if you consider it being related).
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License