Topic "Problem with foreign character file and directory names"

Author Message
getmeoutofhere
[View user's profile]

Joined: 2007-11-04
Posts: 3
I am attempting to transfer files from an XP computer to an Ubuntu 7.04 computer, using WinSCP. Overall the program works very well. However, I am unable to accurately transfer the names of folders and files, that contain diacriticals. There are a number of names that have Polish and Slovak characters in Windows XP, and when they appear on the other computer they are stripped out, and replaced with diamonds with question marks. Both computers have installed on them the relevant support for Polish and Slovak characters. Any ideas? Thanks.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
What protocol are you using? What is your server? What is your UTF-8 session settings?
_________________
Martin Prikryl
getmeoutofhere
[View user's profile]

Joined: 2007-11-04
Posts: 3
I'm not a sophisticated user, and I just wanted a simple system to transfer files from my wife's XP machine to an Ubuntu 7.04 machine. Having had no problems transferring files between two Ubuntu machines, using ssh, I didn't think there would be much of a problem. I was using the SFTP protocol, to transfer using Winscp, XP => Ubuntu. I tried ticking the advanced options, and clicking OFF for server does not use UTF-8, but that didn't make any difference, I still had the problems.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
If your server does not support UTF, you may not be able to solve the problem. But I cannot tell as I do no know what server are you using.
_________________
Martin Prikryl
getmeoutofhere
[View user's profile]

Joined: 2007-11-04
Posts: 3
Thanks for your reply. I don't think UTF-8 support is a problem - the Ubuntu machine, acting as a server, has no problems with UTF-8 - as I said, I can transfer foreign character files names without corruption, between Ubuntu machines, using SSH (openssh). The problem is I believe with the transfer mechanism, and that's WinSCP.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
getmeoutofhere wrote:
Thanks for your reply. I don't think UTF-8 support is a problem - the Ubuntu machine, acting as a server, has no problems with UTF-8 - as I said, I can transfer foreign character files names without corruption, between Ubuntu machines, using SSH (openssh). The problem is I believe with the transfer mechanism, and that's WinSCP.

I haven't meant the server as a machine, but the SFTP server. Knowing now it is OpenSSH... It does not support UTF-8, AFAIK. The fact you are able to transfer file correctly between two Ubuntu machines means nothing, as both sides are using the same locale encoding.
_________________
Martin Prikryl
Cortex

Guest


This is WinSCP which could have first a problem with UTF8. No need to start a down or upload to see it.
Create a folder with a name containing a UTF8 caracter, for example U+FF3F "fullwidth underscore", and try to navigate to it with WinSCP: you can't, winSCP said that it doesn't exist (so you won't be able to upload it)...
Roger

Guest


I have alsp problem with some charecter.

My disk is connect to a Linksys and I can use for example but not when I use WinSCP
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
Cortex wrote:
This is WinSCP which could have first a problem with UTF8. No need to start a down or upload to see it.
Create a folder with a name containing a UTF8 caracter, for example U+FF3F "fullwidth underscore", and try to navigate to it with WinSCP: you can't, winSCP said that it doesn't exist (so you won't be able to upload it)...

Still, I do not think it is problem of WinSCP. what server do you use?
My guess is that the server reports the name of the directory with normal underscore, because it does not support Unicode. Hence it cannot after find the directory, when WinSCP requests to list its content.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
Roger wrote:
My disk is connect to a Linksys and I can use for example but not when I use WinSCP

Please read FAQ. If that does not help, come back.
_________________
Martin Prikryl
Roger

Guest


martin wrote:
Roger wrote:
My disk is connect to a Linksys and I can use for example but not when I use WinSCP

Please read FAQ. If that does not help, come back.


So if I only can use FTP is it not supported?

"For SCP and FTP protocols filename encoding conversion is not supported at all"
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
Roger wrote:
So if I only can use FTP is it not supported?

Well, in fact it is. I have updated the FAQ.
_________________
Martin Prikryl
Guest




martin wrote:
Roger wrote:
So if I only can use FTP is it not supported?

Well, in fact it is. I have updated the FAQ.


Okey, Have you any timeframe for 4.1.0 ?

Thanks
huotg01
[View user's profile]

Joined: 2008-03-07
Posts: 2
Location: Canada
I seem to have a similar problem.

I have a "NAS" on my LAN (WD MyBook World). I setup shared directory on it.

Two cases with the same laptop:
    when I map the drive directly throuhgt Windows Explorer, the accented characters are there.
    when I access the drive throught WinSCP, no more accented characters


I read the FAQ but...I'm not sure of what should be checked.

Thanks for your help.

G.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
Quote:
Okey, Have you any timeframe for 4.1.0 ?

In a week or so. But maybe you have missed the point. It already works in current release! Just that the option is on SFTP tab, although it affect FTP sessions as well.
_________________
Martin Prikryl
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
huotg01 wrote:
Two cases with the same laptop:
    when I map the drive directly throuhgt Windows Explorer, the accented characters are there.
    when I access the drive throught WinSCP, no more accented characters


I read the FAQ but...I'm not sure of what should be checked.

Then, the "Remark" section of the FAQ applies to you.
_________________
Martin Prikryl
huotg01
[View user's profile]

Joined: 2008-03-07
Posts: 2
Location: Canada
I have read it. Sorry to ask that Sad , but what should I understand ?

I may be blind to the obvious !...

Thanks
Roger

Guest


martin wrote:
Quote:
Okey, Have you any timeframe for 4.1.0 ?

In a week or so. But maybe you have missed the point. It already works in current release! Just that the option is on SFTP tab, although it affect FTP sessions as well.


Thanks, No It works better with foreign characters. But

when I syncronize, the source have 894 files (598MB) and the remote directory have only 880 files (579MB). Have I still problem with same files with foreign caracters?
Roger

Guest


Roger wrote:
martin wrote:
Quote:
Okey, Have you any timeframe for 4.1.0 ?

In a week or so. But maybe you have missed the point. It already works in current release! Just that the option is on SFTP tab, although it affect FTP sessions as well.


Thanks, No It works better with foreign characters. But

when I syncronize, the source have 894 files (598MB) and the remote directory have only 880 files (579MB). Have I still problem with same files with foreign caracters?


After a syncronize the target file date is not the same as the source. The file got a new file date (date of today). So the next syncronize will be wrong.
jta

Guest


Having read a number of threads with info about UTF-8 charset, I am still without a solution to a problem with copying files from my windows PC to my Buffalo LinkStation NAS device.

The Buffalo uses ISO8859-15 charset. My Windows is configured with locale "Finnish". When synchronizing folders between the two, WinSCP wants to remove older versions of the files and folders in the target drive. However, the names are not shown correctly, and thus, removing is not successful. I have tried with UTF-8 off and on and auto, changed the Windows Region & Language -> Administrative -> System locale from none to Finnish, changed the Buffalo NAS language setting from 8859-1 to 8859-15 (there is no UTF8, there). There is no change, at all, in how WinSCP displays incorrectly the filename.

Example:
A file "Jääskinen Slides.pdf" on the Buffalo NAS comes up in the WinSCP Synchronize checklist as shown in the attached file (sorry, was not able to copy-paste it here)

Is there any way to make the WinSCP read filenames on Buffalo NAS correctly, please?
ScreenHunter_25 Dec. 27 19.13.jpg (4.31 KB)

Description: How WinSCP reads the file named "Jääskinen Slides.pdf"

ScreenHunter_25 Dec. 27 19.13.jpg

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25310
Location: Prague, Czechia
jta wrote:
Having read a number of threads with info about UTF-8 charset, I am still without a solution to a problem with copying files from my windows PC to my Buffalo LinkStation NAS device.

Please start a new thread and attach a full session log file showing the problem (using the latest version of WinSCP) and some screenshots.

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License