Two problems: hanging uploads and multiple file select

Advertisement

JHSachs
Joined:
Posts:
5

Two problems: hanging uploads and multiple file select

I'm running WinSCP version 4.0.7 under Windows XP. I've recently started having problems with flaky connects. Typically the first time I try to upload a file after I connect, the upload approaches the end of the file and then hangs. I get a timeout and lost connection, and am left with a zero-length file on the host. Then I reconnect and repeat the upload, and it works perfectly.

I've also had problems selecting multiple files on the local system (but not the host) with control-click and shift-click. Sometimes these operations work normally. Other times, when I hold down the control or shift key and click, the program displays a broken line around the file I clicked on, and the previous selections (if any) are not changed.

Any ideas what is happening? I love the program otherwise, but these two problems are making it very difficult to use.

Reply with quote

Advertisement

JRB_BMB
Joined:
Posts:
24
Location:
Midlands, UK

Try upgrading to the latest version 4.1.5 and re-test. If the problems still arise then post log files etc to help with a diagnosis.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

JRB_BMB wrote:

Try upgrading to the latest version 4.1.5 and re-test. If the problems still arise then post log files etc to help with a diagnosis.
Also let us know, what protocol are you using.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: Two problems: hanging uploads and multiple file select

JHSachs wrote:

I've also had problems selecting multiple files on the local system (but not the host) with control-click and shift-click. Sometimes these operations work normally. Other times, when I hold down the control or shift key and click, the program displays a broken line around the file I clicked on, and the previous selections (if any) are not changed.
Are you able to reproduce that or does it happen randomly?
_________________
Martin Prikryl

Reply with quote

JHSachs
Joined:
Posts:
5

Are you able to reproduce that or does it happen randomly?

Absolutely reproducible since it started. I'll install the new version and report back.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Again: What protocol are you using?
_________________
Martin Prikryl

Reply with quote

JHSachs
Joined:
Posts:
5

I tried version 4.1.6 (with a different host) and got the same problem.

Please tell me where to find the log files. There's nothing that looks like one in the WinSCP directory, or in its only subdirectory, PuTTY.

With both hosts, the protocol is FTP.

Reply with quote

Advertisement

JHSachs
Joined:
Posts:
5

PRELIMINARY


257 "/httpdocs" is current directory.
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,155
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
Directory listing successful
Changing directory to "pix".
CWD pix
250 CWD command successful.
Getting current directory name.
PWD
257 "/httpdocs/pix" is current directory.
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,157
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
Directory listing successful
REST 0
350 Restarting at 0.

FIRST ATTEMPT TO UPLOAD A FILE


Copying 1 files/directories to remote directory "/httpdocs/pix/"
PrTime: Yes; PrRO: Yes; Rght: rw-r--r--; PrR: No (No); FnCs: N; RIC: 01; Resume: S (102400); CalcS: Yes; Mask: *.*
TM: M; ClAr: No; CPS: 0; ExclM(No):
AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
File: "C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt"
PrTime: Yes; PrRO: Yes; Rght: rw-r--r--; PrR: No (No); FnCs: N; RIC: 01; Resume: S (102400); CalcS: Yes; Mask: *.*
TM: M; ClAr: No; CPS: 0; ExclM(No):
AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
File: "C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt"
Copying "C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt" to remote directory started.
Ascii transfer mode selected.
Starting upload of C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,159
200 PORT command successful.
STOR NatLinkInstallLog.txt
150 Opening ASCII mode data connection for NatLinkInstallLog.txt.
Timeout detected.
Copying files to remote side failed.
Starting upload of C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,159
200 PORT command successful.
STOR NatLinkInstallLog.txt
150 Opening ASCII mode data connection for NatLinkInstallLog.txt.

IT SITS SHOWING 0% TRANSFERRED UNTIL A TIMEOUT OCCURS

Timeout detected.
Copying files to remote side failed.
Connection was lost, asking what to do.
Asking user:
Lost connection. ("Timeout detected.","Copying files to remote side failed.","Opening ASCII mode data connection for NatLinkInstallLog.txt.")
Asking user:
Lost connection. ("Timeout detected.","Copying files to remote side failed.","Opening ASCII mode data connection for NatLinkInstallLog.txt.")
Connecting to jhsachs.com ...
Connected with jhsachs.com. Waiting for welcome message...
220 Microsoft FTP Service
USER jsachs
331 Password required for jsachs.
PASS *******
230 User jsachs logged in.
SYST
215 Windows_NT
FEAT
211-FEAT
SIZE
MDTM
211 END
Connected
Doing startup conversation with host.
Changing directory to "/httpdocs/pix".
Synchronizing current directory "/httpdocs/pix".
CWD /httpdocs/pix
250 CWD command successful.
CWD /httpdocs/pix
250 CWD command successful.
Getting current directory name.
PWD
257 "/httpdocs/pix" is current directory.
Startup conversation with host finished.
File: "C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt"
Copying "C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt" to remote directory started.
Ascii transfer mode selected.
Starting upload of C:\Documents and Settings\Jonathan Sachs\My Documents\NatLinkInstallLog.txt
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,164
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,166
200 PORT command successful.
APPE NatLinkInstallLog.txt
150 Opening ASCII mode data connection for NatLinkInstallLog.txt.
226 Transfer complete.
Upload successful
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,64,14,168
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
Directory listing successful

Reply with quote

Advertisement

You can post new topics in this forum