Ignore permission error - when running from script

Advertisement

user33
Guest

Ignore permission error - when running from script

We currently use winscp 4.0.3 in script form to place transmit numerous files to external servers.

This has been running fine, until this morning, when I added a new job.

The error recieved is: Upload of file 'test.csv' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn on 'Ignore permission errors' option.

I just want to ignore this error, the file goes ok - I just need a switch to use at command line in a script which ignores?

thanks

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Ignore permission error - when running from script

Please read FAQ. If that does not help, come back.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Ignore permission error - when running from script

This request has been added to tracker.
_________________
Martin Prikryl

Reply with quote

user33
Guest

thanks for respose - but thats not any clearer for me.

This is in a batch with a lot of others which are all working ok, and I really dont want to mess with the rest of them, so I really need to try and do this at script level in the cmd file.

is this possible? if not, can you give me a little example of how you would do this using the method you linked me to? perhaps I will hav to call the ini file for this oen customer?

Reply with quote

Advertisement

cdlvj
Joined:
Posts:
13

I have hit this same error, 1st time in many moons.
What can the client at the server end do to prevent this error?

All our clients have it set correctly except for one.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

cdlvj wrote:

I have hit this same error, 1st time in many moons.
What can the client at the server end do to prevent this error?

All our clients have it set correctly except for one.
The file must be owned by the user who is overwritting it. It is not enough to have write permissions to update timestamps and/or set permissions.
_________________
Martin Prikryl

Reply with quote

matmak
Joined:
Posts:
1
Location:
Seattle, WA

-nopermissions and -nopreservetime don't avoid perm errors

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.

winscp> put -nopermissions -nopreservetime "D:\filestore\etl\data\geography\Region Map Paths.csv" SSRS/
D:Region Map Paths.csv | 1456 KiB | 1789.1 KiB/s | binary | 100%
Upload of file 'Region Map Paths.csv' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn on 'Ignore permission errors' option.
The server does not support the operation.
Error code: 8
Error message from server (en): The request is not supported.
Request code: 9
(A)bort, (R)etry, (S)kip, Ski(p) all: Abort
winscp>

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: -nopermissions and -nopreservetime don't avoid perm errors

matmak wrote:

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.
What version of WinSCP are you using?
_________________
Martin Prikryl

Reply with quote

Advertisement

Psi, Inc
Guest

Re: -nopermissions and -nopreservetime don't avoid perm errors

martin wrote:

matmak wrote:

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.
What version of WinSCP are you using?

Using Version 4.2.9 Build 938, I was having the same problems until I added the
-nopermissions and -nopreservetime. Worked like a charm after that.

Reply with quote

user123
Guest

Re: -nopermissions and -nopreservetime don't avoid perm errors

Psi, Inc wrote:

martin wrote:

matmak wrote:

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.
What version of WinSCP are you using?

Using Version 4.2.9 Build 938, I was having the same problems until I added the
-nopermissions and -nopreservetime. Worked like a charm after that.

We're using Version 4.0.4 Build 346, and have the same problem. Added -nopermissions and -nopreservetime does not work, error:
File or folder '-nopermissions' does not exist. Any ideas?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: -nopermissions and -nopreservetime don't avoid perm errors

user123 wrote:

We're using Version 4.0.4 Build 346, and have the same problem. Added -nopermissions and -nopreservetime does not work, error:
File or folder '-nopermissions' does not exist. Any ideas?
Please read FAQ:
https://winscp.net/eng/docs/faq_script_switch
https://winscp.net/eng/docs/faq_script_ini
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum