Bad file copy

Advertisement

deepthinker
Joined:
Posts:
3
Location:
Bristol, England

Bad file copy

WinSCP ver 4.1.8 (the latest !)

I have a file here which is 24,232 bytes long but despite copying from Windows-XP to my Linux machine in BINARY mode the copy is corrupt and only 24,231 bytes in length. This is repeatable. Help !

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Bad file copy

Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl

Reply with quote

deepthinker
Joined:
Posts:
3
Location:
Bristol, England

Re: Bad file copy

martin wrote:

Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

Thanks. The log shows ASCII file transfer, even though BINARY was selected in Transfer Settings in the Copy pop-up box.

I have changed the defaults so that all files are sent in binary.

Is it a bug that setting Binary (or anything else) in Transfer Settings does not override the defaults ?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Bad file copy

How do you upload the file?
_________________
Martin Prikryl

Reply with quote

deepthinker
Joined:
Posts:
3
Location:
Bristol, England

Re: Bad file copy

martin wrote:

How do you upload the file?

1. Select the file to be copied on the left-hand panel
2. Press the F5 key
3. In Transfer Settings, select Binary

Adrian

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Bad file copy

I'll send you a debug version soon.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum