.tpl files don't update

Advertisement

Guest

.tpl files don't update

I was using the 4.19 version to update a site that using Smarty PHP templates .tpl files. The first upload would display the change in the browser. I then edited the .tpl file again and uploaded. The new changes didn't display in the browser and only the first round edit displayed in the browser. I've used several other SFTP clients and the same procedure worked just as expected and the edits would display in the browser. I went back to WinSCP and then typed in the path the the .tpl file in the browser and I saw the latest edits to the file. I then went back to the webpage and the 1st round of edits displayed which is wrong. I couldn't get rid of this problem, cleared cache.. everything.. Very strange. I did the same procedure with .php and .html files and it worked fine with WinSCP. So, I'll have to use a different SFTP client unless this is resolved :(

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: .tpl files don't update

.tpl files are most probably cached by your webserver or web application. It may update the cache only when timestamp of the template is newer then the cache. Due to a way WinSCP may shift timestamp of the uploaded file, the resulting timestamp may be older even after update then the cache. I would try to choose different daylight saving time mode. Also see documentation.

Reply with quote

Advertisement

You can post new topics in this forum