Topic "Option Exclude command not working."

Author Message
bderry71

Guest


I have the following script:

Code:
option batch continue
option confirm off
option synchdelete on

option exclude "D:\Share\Students\*"
option exclude "G:\Business\McMahon\2009 YearTech\Digital Photos\*"
option exclude "G:\Business\McMahon\2009 YearTech\New Pictures\*"
option exclude "G:\Business\Sullivan\Yearbook2010\Pictures\*"
option exclude "G:\RECYCLER\*"
option exclude "G:\System Volume Information\*"

synchronize remote G:\ HighSchool/StudentData

exit



With this script WinSCP is transferring stuff that I have excluded. I added this line recently to filter out some pictures which are being backed up differently.

option exclude "G:\Business\Sullivan\Yearbook2010\Pictures\*"

It is ignoring this line. I removed the other synchronize statements so that I can figure out why it is transferring stuff that I don't want transferred.

Regards,
Ben
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Only the last exclude mask applies. You need to put multiple masks into single line, separating them by semicolon. See documentation.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License