Topic "WinSCP 4.2.4 Beta BUG with Permissions"

Author Message
dude
[View user's profile]

Joined: 2009-11-06
Posts: 1
I was just trying out the new beta and noticed that the permissions were not being set properly on my server. What I discovered was that the permissions were set as defined in Preferences->Transfer->Upload options even if the "Set permissions" box is UNchecked. I have another machine running WinSCP 4.0.5 and have confirmed that this problem does not occur with that. Seems like a bug to me. In case it makes a difference, my server is running Centos 5. Thanks...

P.S. Protocol is SCP and Windows version is XP Pro SP3
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License