File must be specified by library/file.member ???

Advertisement

Guest

File must be specified by library/file.member ???

When trying to send a file to my FTP server I get the following. I have no issues downloading a file from the server, only when i'm sending. Any suggestions would be greatly appreciated. Please let me know if there is more information you might need.

Error Occured: Sending file to FMS.
winscp> option batch abort
batch abort
winscp> option confirm off
confirm off
winscp> open ftp://USer:Password@ftpServer
Connecting to ftpServer ...
Connected with ftpServer. Waiting for welcome message...
Connected
Starting the session...
Reading remote directory...
Session started.
Active session: [1] User@ftpServer
winscp> lcd C:\Test
C:\Test
winscp> cd OUT
OUT
winscp> put C:\Test\Test.txt
C:\Test\Test.txt | 0 KiB | 0.0 KiB/s | binary | 0%
Error transferring file 'C:\Test\Test.txt'.
Copying files to remote side failed.

File must be specified by library/file.member.
(A)bort, (R)etry, (S)kip, Ski(p) all: Abort

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: File must be specified by library/file.member ???

Is it VMS?
_________________
Martin Prikryl

Reply with quote

Guest

Re: File must be specified by library/file.member ???

martin wrote:

Is it VMS?

Being that I pretty much have no idea what VMS is, I'm going to go out on a limb and say no.

I'm using Windows XP, and I am trying to send to an IBM AS/400 server. Does this answer the question?

Reply with quote

LCross
Joined:
Posts:
2
Location:
San Antonio,TX

Re: File must be specified by library/file.member ???

martin wrote:

Is it VMS?

Let me also add that I get this error message as well when I use the "ls" command. It almost seems like some type of configuration issue, but i have uninstalled and reinstalled the software with no success. Also after reading further on the subject of VMS, i do not believe that the server is VMS.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: File must be specified by library/file.member ???

I'm afraid WinSCP cannot deal with IBM AS/400 (nor with VMS).

This issue is being tracked already.
_________________
Martin Prikryl

Reply with quote

Guest

I am using this on iSeries and it works on some of the systems but not all of them.
I am checking to see if this has an update to correct.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Anonymous wrote:

I am using this on iSeries and it works on some of the systems but not all of them.
I am checking to see if this has an update to correct.
Please attach a full log file both from a system where WinSCP works and where it does not? (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Guest

Just for info about "File must be specified by library/file.member"
and "I am using this on iSeries and it works on some of the systems but not all of them."

The FTP server on IBMi (successor of model AS/400, but everyone uses the old name) has lots of attributes.
One of them sets the FTP default target: from/into the DB2 database library system, or from/into the Unix file system on the machine.
The error message indicates that DB2 is set, but a Unix path is set in WinSCP.

Check and change this with command CHGFTPA +F4 to prompt the settings. Switch all parameters on using F9. Display the parameter names with F11. Page down to NAMEFMT and CURDIR.
Cursorposition plus F1 explains allways everything.
"NAMEFMT = *PATH" sends all incoming FTP connections at startup into IBMi's Unix server.
"CURDIR = *HOMEDIR" means: use user's home directory from his user profile. To check it, use "DSPUSRPRF username", and page down to the very end. You'll see e.g. /home. Use CHGUSRPRF to change it.

If you log in from WinSCP now, you will be in /home, and the error message above will not show up.

Of course, like on any Unix based system, there is a fancy-mousy-clicky surface for all of this, as software or for browser. But command line is faster.

Reply with quote

Advertisement

Guest

Hello, a way to solve this temporarily is to execute the command SITE NAMEFMT 1 and that will shift the remote iSeries into the expected naming mode.

martin wrote:

Anonymous wrote:

I am using this on iSeries and it works on some of the systems but not all of them.
I am checking to see if this has an update to correct.
Please attach a full log file both from a system where WinSCP works and where it does not? (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum