Scripted Get not working

Advertisement

schusr
Joined:
Posts:
4

Scripted Get not working

Copied and pasted get example from help, would not download the file. Document example has errors suggest update.

Searched for the word get in this forum, no results.

Nothing obvious in the browse of a couple of other threads.

This script fails to retrieve college.xml

option batch on
option confirm off
open bob:bob123@host2
cd /export/home/bob
option transfer binary
get college.xml
close
exit



batch on
confirm off
Searching for host...
Connecting to host...
Authenticating...
Using username "bob".
Authenticating with pre-entered password.
Authenticated.
Starting the session...
Reading remote directory...
Session started.
Active session: [1] bob@host2
/export/home/bob
transfer binary
college.xml | 0 KiB | 0.0 KiB/s | binary | 100%
Session 'bob@host2' closed.
No session.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Scripted Get not working

Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl

Reply with quote

schusr
Joined:
Posts:
4

Re: Scripted Get not working

Well command line /log does not work and my Preferences window has no Logging category!

Using WinSCP 4.1.8 Build 415

Maybe I don't have local administration permissions? I did not install WinSCP

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Scripted Get not working

First make sure you use the latest version. When opening Preferences dialog from Login dialog, the Logging tab is not shown because it is already on the Login dialog.
_________________
Martin Prikryl

Reply with quote

schusr
Joined:
Posts:
4

Re: Scripted Get not working

martin wrote:

First make sure you use the latest version. When opening Preferences dialog from Login dialog, the Logging tab is not shown because it is already on the Login dialog.

Okay do I really need to upgrade?

Enabled logging in the Login/Preferences window but the command line /log still does not generate a log file anywhere.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Scripted Get not working

schusr wrote:

Okay do I really need to upgrade?
I do not support old version.

Enabled logging in the Login/Preferences window but the command line /log still does not generate a log file anywhere.
Post an example of command-line you are using.
_________________
Martin Prikryl

Reply with quote

schusr
Joined:
Posts:
4

Re: Scripted Get not working

Got it working.

Upgraded to latest version which had error about remote system's key not in cache. Manually logged in once and then script worked.

Reply with quote

Advertisement

You can post new topics in this forum