Topic "Issue: Automated script not downloading files with no ext"

Author Message
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
Hi Martin,

I have a script that runs @ 3:20 each morning. This script has never been quite right. I have only recently discovered the "-criteria=size" switch which has resolved a problem of re-downloading files due to incorrect time stamps between servers. However, now that this switch is in place, the script doesn't seem to download files with no extension when automated?

When the script is run manually all files download fine...

I have logs showing this and can also send you the batch files that I am using to initiate the connection.


Thank you for your time and your continued support for this great application.
Cheers.
Advertisements
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
I should also add that this automation is handled via Windows 2003 scheduled tasks, which have an exit code of 0x0 always (indicating no errors for the scheduled task process at least)

Regards.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
Thanks Martin,

Here is the log showing the error over 3 days and 2 WinSCP versions (updated to the latest to try and resolve, which did not work)

<invalid hyperlink removed by admin>

The automated run is at 3:20am each morning, so anything run outside of this time (8:30am, 9am etc) is me manually running the script.


Regards.
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
This mornings automated download successfully picked up the files.

I have saved the log for this also, if you can see any difference in there?


<invalid hyperlink removed by admin>


Thanks.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
In both log files I can see that some file CDNZVF-M2* was downloaded to local directory (E:\Vodafone@Host.IPNZcdrs or E:\VodafoneNZcdrs). So you believe the file was not downloaded in one of the cases?
_________________
Martin Prikryl
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
Yes.

In the first log you can see on 05/09/2010 @ 3:20am when the script ran, it downloaded the TXT file and CDNZVF-M2 file as normal. However come 06/09/2010 @ 3:20am when it ran the following day, it failed to download the CDNZVF-M2 file and only picked up the TXT file. Then that morning when I checked the job status, I saw the CDNZVF-M2 file has not been downloaded, and manually ran the job, which then got the correct file without error.

This also happened the next day 07/09/2010.


Regards.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
OK, but I see no difference (in timestamp nor size) between listings from 05/09/2010 @ 3:20am and 06/09/2010 @ 3:20am, except for the M22010-09-04.txt. So if the local files are still present from 05/09/2010, there's no need to (re)download any of the CDNZVF-M2* files.
_________________
Martin Prikryl
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
These CDNZVF-M2 files appear on the remote server every morning before 3:20am, and a new one will be there each day. So the script is sometimes downloading these files (which have no extension) and sometimes not. When I run the script manually in the morning is picks it up however, which I cannot explain.

So basically every morning @ 3:20am the script should be downloading 2 files, a TXT and one with no extension, but this is not always happening.


Cheers.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
As you can see yourself in the log, there was no file added between 05/09/2010 @ 3:20am and 06/09/2010 @ 3:20am. Only on 06/09/2010 @ 8:26am two new CDNZVF-M2* files were present (and downloaded).
Emexus
[View user's profile]

Joined: 2010-04-12
Posts: 8
Location: Tasmania
So it's true!

Sorry to waste your time on this Martin. I didn't notice that previously when looking through the logs... *slaps self on head*


Best Regards!
isidorosx

Guest


I want to transfer music using WinSCP from my Pc to iphone 3gs...but when i open WinSCP and go to "library" to find "downloads" i had a problem!i can t find "downloads"...please help me or make me know an other way to transfer music from Pc to my iphone 3Gs!! tnx
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License