Topic "Error due to Load Balancer IP"

Author Message
nonotford

Guest


WinSCP v4.2.7 (GUI mode on win2k3 sp2) is sending an error when we use FTPS with a load balancer. The client shows the following error:
-----------------------------------------------------------------------------------------------
Using host address <load balancer ip> instead of the one suggested by the server: <server ip>
Can't establish SSL connection
Copying files from remote side failed.
File receive OK.
-----------------------------------------------------------------------------------------------
We would like WinSCP to move on without an error (which requires user interaction). This IP discrepancy should be normal expected behavior, and not treated as an error.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
zhillma
[View user's profile]

Joined: 2015-05-28
Posts: 1
Location: South Glos
Hi, I know this is a very old topic but it is still relvant to me.

I am using WinSCP 4.3.7 with a command line script file and am experiencing the same issue. The connection is via FTP with TLS (Explicit).

The script uses the following block of code (last 2 lines repeated many times)

open 'profile'
option batch continue
cd /folder
get -delete *Report.txt

Every now and then the transfer fails with the error mentioned, an empty files is created but the real file is left on the server. The job itself completes with no error (I guess due to the 'continue' option)

The log shows these lines
. 2015-05-28 09:51:20.840 File: "/CMUM1/XXX_Risk_Report/XXX_CMUM1_20150526_RiskReport.txt"
. 2015-05-28 09:51:20.842 Copying "/CMUM1/XXX_Risk_Report/XXX_CMUM1_20150526_RiskReport.txt" to local directory started.
. 2015-05-28 09:51:20.843 Ascii transfer mode selected.
. 2015-05-28 09:51:20.845 Starting download of /CMUM1/XXX_Risk_Report/XXX_CMUM1_20150526_RiskReport.txt
> 2015-05-28 09:51:20.847 TYPE A
< 2015-05-28 09:51:20.876 200 Type set to A.
> 2015-05-28 09:51:20.878 PASV
< 2015-05-28 09:51:20.904 227 Entering Passive Mode (XXX,YYY,ZZZ,210,213,16).
. 2015-05-28 09:51:20.910 Using host address AAA.BBB.CCC.147 instead of the one suggested by the server: XXX.YYY.ZZZ.210
> 2015-05-28 09:51:20.912 RETR XXX_CMUM1_20150526_RiskReport.txt
< 2015-05-28 09:51:20.984 150 Opening ASCII mode data connection.
. 2015-05-28 09:51:21.698 SSL connection established
. 2015-05-28 09:51:21.700 Copying files from remote side failed.
. 2015-05-28 09:51:21.701 Got reply 4 to the command 4
< 2015-05-28 09:51:21.701 226 Transfer complete.
* 2015-05-28 09:51:21.704 (ExtException) Using host address AAA.BBB.CCC.147 instead of the one suggested by the server: XXX.YYY.ZZZ.210
* 2015-05-28 09:51:21.704 Copying files from remote side failed.
* 2015-05-28 09:51:21.705 Transfer complete.
. 2015-05-28 09:51:21.706 Asking user:
. 2015-05-28 09:51:21.707 Error transferring file '/CMUM1/XXX_Risk_Report/XXX_CMUM1_20150526_RiskReport.txt'. ("Using host address AAA.BBB.CCC.147 instead of the one suggested by the server: XXX.YYY.ZZZ.210","Copying files from remote side failed.","Transfer complete.")
* 2015-05-28 09:51:21.708 (EScpSkipFile) Error transferring file '/CMUM1/XXX_Risk_Report/XXX_CMUM1_20150526_RiskReport.txt'.
* 2015-05-28 09:51:21.709 Using host address AAA.BBB.CCC.147 instead of the one suggested by the server: XXX.YYY.ZZZ.210
* 2015-05-28 09:51:21.710 Copying files from remote side failed.
* 2015-05-28 09:51:21.710 Transfer complete.

Is there anything that can be done to handle the different IP address better, or get the transfer to retry?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
Please attach a full log file showing the problem using the latest version of WinSCP.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License