Topic "Cannot open a folder if NAME is identical to parent folder"

Author Message
savingface78
[View user's profile]

Joined: 2011-01-17
Posts: 5
Location: PA
It appears this is a bug. One Cannot open a folder if the folder NAME is identical to parent folder name.

For example I cannot open this folder:
...\InstallMedia\InstallMedia\

-I can open the folder fine when using Windows built in FTP.
-If I rename the child folder I can open it.
-Also If I rename the parent folder, I can open the child folder.


------------
WinSCP Version 4.2.9 Build 938
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
savingface78
[View user's profile]

Joined: 2011-01-17
Posts: 5
Location: PA
Thanks for your reply. Here is the requested log:

. 2011-01-19 14:46:44.538 Session upkeep
. 2011-01-19 14:46:44.538 Session upkeep
. 2011-01-19 14:46:45.038 Session upkeep
. 2011-01-19 14:46:45.538 Session upkeep
. 2011-01-19 14:46:46.038 Session upkeep
. 2011-01-19 14:46:46.538 Session upkeep
. 2011-01-19 14:46:46.850 Cached directory change via "InstallMedia" to "/InstallMedia".
. 2011-01-19 14:46:46.850 Getting current directory name.
. 2011-01-19 14:46:46.850 Retrieving directory listing...
> 2011-01-19 14:46:46.850 CWD /InstallMedia/
< 2011-01-19 14:46:46.850 250 CWD command successful.
> 2011-01-19 14:46:46.850 PWD
< 2011-01-19 14:46:46.850 257 "/InstallMedia" is current directory.
> 2011-01-19 14:46:46.850 TYPE A
< 2011-01-19 14:46:46.850 200 Type set to A.
> 2011-01-19 14:46:46.850 PORT 1**,**,***,**,**,25 [(Masked for privacy)]
< 2011-01-19 14:46:46.866 200 PORT command successful.
> 2011-01-19 14:46:46.866 LIST -a
< 2011-01-19 14:46:46.866 150 Opening ASCII mode data connection for /bin/ls.
. 2011-01-19 14:46:46.866 01-05-11 06:52PM <DIR> IndividualInstallers
. 2011-01-19 14:46:46.866 12-22-10 05:31PM <DIR> InstallMedia
. 2011-01-19 14:46:46.866 10-13-10 12:55PM <DIR> OracleInstallMedia
. 2011-01-19 14:46:46.866 07-07-10 10:24AM <DIR> SoftwareUpdaters
< 2011-01-19 14:46:47.007 226 Transfer complete.
. 2011-01-19 14:46:47.007 Directory listing successful
. 2011-01-19 14:46:47.007 Got reply 1 to the command 2
. 2011-01-19 14:46:47.038 Session upkeep
. 2011-01-19 14:46:47.538 Session upkeep
. 2011-01-19 14:46:48.038 Session upkeep
. 2011-01-19 14:46:48.538 Session upkeep
. 2011-01-19 14:46:48.538 Cached directory change via "InstallMedia" to "/InstallMedia".
. 2011-01-19 14:46:48.538 Getting current directory name.
. 2011-01-19 14:46:48.538 Directory content loaded from cache.
. 2011-01-19 14:46:49.038 Session upkeep
. 2011-01-19 14:46:49.538 Session upkeep
. 2011-01-19 14:46:50.038 Session upkeep
. 2011-01-19 14:46:50.538 Session upkeep
. 2011-01-19 14:46:51.038 Session upkeep
. 2011-01-19 14:46:51.538 Session upkeep
. 2011-01-19 14:46:52.038 Session upkeep
. 2011-01-19 14:46:52.538 Session upkeep
. 2011-01-19 14:46:53.038 Session upkeep
. 2011-01-19 14:46:53.538 Session upkeep
. 2011-01-19 14:46:54.163 Got reply 1004 to the command 2
. 2011-01-19 14:46:54.163 Disconnected from server
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
I have sent you an email.
_________________
Martin Prikryl
savingface78
[View user's profile]

Joined: 2011-01-17
Posts: 5
Location: PA
Hi Martin,
I've replied to your email with the debug file. It seems to work with the files you gave me.


prikryl wrote:
I have sent you an email.
savingface78
[View user's profile]

Joined: 2011-01-17
Posts: 5
Location: PA
The problem seems to lay with my old INI file.

It works as long as I don't use my previous INI file. If I allow your 2 new files you sent me to create a new INI file, and then choose to save the password it will work.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
From the log it looks like it may be connected to directory change cache (which is stored in the INI file). If it ever happens again, please let me know.
_________________
Martin Prikryl
savingface78
[View user's profile]

Joined: 2011-01-17
Posts: 5
Location: PA
Sorry for the slow reply, the notification went to my spam folder. Thanks for your help with this - much appreciated.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License