Synchronizing mess after daylight saving time

Advertisement

abcd
Guest

Synchronizing mess after daylight saving time

Hi,

Firstly, thanks for your great WinSCP software. It's been a tremendous help.

I usually synchronize a folder with an FTP server with modification time as a comparison criteria. This works great for a while until daylight saving time (i.e. summer time) came a few weeks ago. After DST comes, basically all files are declared different because the 1 hour offset. I thought it was a trivial glitch and copied all files in the folder to a local folder. However, this happens again and again. The local files are always 1 hour offset from the remote ones. So, I think it's a bug.

Thanks,
abcd

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,539
Location:
Prague, Czechia

Re: Synchronizing mess after daylight saving time

What DST option have you set for your session?
_________________
Martin Prikryl

Reply with quote

Advertisement

abcd
Guest

Sorry if I appear to be a nag, but yes, for FTP, it is disabled. Here's how to reproduce it:
1. Start WinSCP (ver 4.3.2)
2. Enable Advanced Option
3. Click "New" button
4. Fill in the host name, user name and password
5. Switch File protocol to FTP (not SFTP or SCP)
6. Click on the "Environment" on the left.
7. Voila. The DST options are disabled.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,539
Location:
Prague, Czechia

I'm sorry, you are right. This is not supported for FTP yet.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum