Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: No Overwrite with get and Wildcards

@martin, @jgarcia1977: Hi, there, I guess you got the wrong order, the right order should be
synchronize local -criteria=none /dir/*(remote first)  C:\ (local second)

No Overwrite with get and Wildcards

Hi All,

I try to get files from remote to local through script, but the local files are overwritten when exists, due this the time is too long.
I tried with:
synchronize local -criteria=none /dir/*  C:\

but this returns an error:
An attempt to browse to the directory «/dir/*\*.*» failed. ("Failed to download the file list from« /dir/*\*.*»,"System error. Code: 3. "," The system cannot find the specified path ")

Please could you help me?

Thanks & BR.

Thank very very much!!

Re: No overwrite existing file

Use synchronize remote -criteria=none instead of put *.*

No overwrite existing file


This is my .bat
@echo off
echo --------------------------
echo Trasferimento FTP avviato anno 2009
echo --------------------------
echo INIZIO %date% %time%
echo INIZIO %date% %time% > c:\LogWinscp2009.txt
E: /script=C:\uploadscript2009.txt >> c:\LogWinscp2009.txt
echo ---------
echo F I N E
echo ---------
echo FINE %date% %time%
echo FINE %date% %time% >> c:\LogWinscp2009.txt

and this is my .txt
option echo off
option batch on
option confirm off
open ftp://username:password@ipaddress
cd /prod01_img_HYPERDOC/PROT/2015
lcd "E:\Protocollo\docs\2015"
put *.*

I wish the existing files are not overwritten but ignored.
Can you help me please?
Thank you very much