Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thank you. it worked for me
"put -nopermissions -nopreservetime -resumesupport=off *.xml" ^

Equivalent settings in

I tried same settings in using following code;
Dim transferOptions As New TransferOptions
transferOptions.ResumeSupport = TransferResumeSupportState.Off

but this gives error that Property is Read Only.

resumesupport switch not working


I've seen a few solutions to turn off transfer resume support but none of them are working for me. And yes, I have read the FAQ. I'm trying to do this using a script. I'm using version 4.2.9

Here is the script I'm using:
option batch abort
option confirm off
open "s"
option transfer binary
cd /user/user/outbox/target
lcd "mylocaldirectory"
put -nopermissions -resumesupport=off -nopreservetime *

I get this error

Unknown switch 'resumesupport'.

What am I doing wrong? Again, I've tried to read the FAQ.

WinSCP is primarily GUI client, so the error messages cannot refer to scripting switches.

Excellent, that worked. I'd recommend adding more text to the error displayed in this instance to suggest the use of the -nopreservetime tag. Thanks again for the quick help. You're a rock star!

Re: Ignore/Skip All Permissions or Resume Support Errors

The -nopermissions and -resumesupport=off is correct. Just add -nopreservetime and you should be fine.

See also:

Ignore/Skip All Permissions or Resume Support Errors

I have a client that immediately grabs all uploaded files to their ftp site once a file handle is closed on the file. This prevents resume support and changing permissions to work. Thus, I'd like to ignore such errors or disable the action causing them, but I haven't been able to find proper documentation on how to do this from a script.

Here is the command line: /script=G:\code\Statement_Upload.txt

Here is the script:
# Automatically abort script on errors 
option batch abort
# Enable overwrite confirmations that conflict with the previous
option confirm on
# Force binary mode transfer
option transfer binary
# Establish the connection to the Statements account
open s
# Change the Local Directory
lcd "X:\statements\ToBeSent"
# Change to the correct Remote directory
cd /
# Upload the files ending with .TXT
put -nopermissions -resumesupport=off *.TXT
# Exit

After running the script I get the following output in the console:
C:\Program Files (x86)\WinSCP> /script=G:\code\Statement_Upload.txt

batch           abort
confirm         on
transfer        binary
Searching for host...
Connecting to host...
Using username "user".
Authenticating with pre-entered password.
Starting the session...
Reading remote directory...
Session started.
Active session: [1]
4061116.TXT               |         82 KiB |   20.9 KiB/s | binary | 100%
Upload of file '4061116.TXT' was successful, but error occurred while setting th
e permissions and/or timestamp. If the problem persists, turn on 'Ignore permiss
ion errors' option.
No such file or directory.
Error code: 2
Error message from server (en): File not found
Request code: 9
(A)bort, (R)etry, (S)kip, Ski(p) all: Abort

C:\Program Files (x86)\WinSCP>

Using WinSCP 5.2.0 (Build 3157) on Windows 7 Professional SP1.