Topic "WinSCP - Loading Problem Files with Dateformat Special Characters"

Author Message
pipo2
[View user's profile]

Joined: 2015-05-11
Posts: 6
I have an interesting one here.

When login in via FTP I am only able to see the folders shop1, however not shop_test, webalizer and 2014a. From the log it looks like a special character issue for the date of a file. So in this case it should be Mär, but Mär is shown. No problem using other ftp clients, it works great, but only WinSCP has problems here. Do you know what that could be or how I can solve it?

. 2015-05-11 11:22:45.905 Connecting to xxx.x.xxx.xx:xxxx ...
< 2015-05-11 11:22:46.055 150 Opening ASCII mode data connection for /bin/ls.
. 2015-05-11 11:22:46.194 insgesamt 56
. 2015-05-11 11:22:46.194 drwxrwx--- 12 www-data safer 4096 8. Mai 07:50 .
. 2015-05-11 11:22:46.194 drwxrws--- 14 www-data safer 4096 19. Mär 15:11 2014a
. 2015-05-11 11:22:46.194 drwxrwx--- 3 www-data safer 4096 11. Nov 20:17 shop1
. 2015-05-11 11:22:46.194 drwxrwx--- 3 www-data safer 4096 6. Mär 13:29 shop_test
. 2015-05-11 11:22:46.194 drwxrwx--- 2 www-data safer 4096 3. Mär 2011 webalizer
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
pipo2
[View user's profile]

Joined: 2015-05-11
Posts: 6
prikryl wrote:
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.


Attached (private only).


PostWinSCP - Loading Problem Files with Dateformat Special Characters
[Reply with quote] [Edit this post]
I have an interesting one here.

When login in via FTP I am only able to see the folders shop1, however not shop_test, webalizer and 2014a. From the log it looks like a special character issue for the date of a file. So in this case it should be Mär, but Mär is shown. No problem using other ftp clients, it works great, but only WinSCP has problems here. Do you know what that could be or how I can solve it?

. 2015-05-11 11:22:45.905 Connecting to xxx.x.xxx.xx:xxxx ...
< 2015-05-11 11:22:46.055 150 Opening ASCII mode data connection for /bin/ls.
. 2015-05-11 11:22:46.194 insgesamt 56
. 2015-05-11 11:22:46.194 drwxrwx--- 12 www-data safer 4096 8. Mai 07:50 .
. 2015-05-11 11:22:46.194 drwxrws--- 14 www-data safer 4096 19. Mär 15:11 2014a
. 2015-05-11 11:22:46.194 drwxrwx--- 3 www-data safer 4096 11. Nov 20:17 shop1
. 2015-05-11 11:22:46.194 drwxrwx--- 3 www-data safer 4096 6. Mär 13:29 shop_test
. 2015-05-11 11:22:46.194 drwxrwx--- 2 www-data safer 4096 3. Mär 2011 webalizer
winscp.log (10.31 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
Try to set UTF-8 encoding for filenames session option to On.
https://winscp.net/eng/docs/ui_login_environment
pipo2
[View user's profile]

Joined: 2015-05-11
Posts: 6
prikryl wrote:
Try to set UTF-8 encoding for filenames session option to On.
https://winscp.net/eng/docs/ui_login_environment


I entered UTF-8 ON to force it however it still does not work. The issue is not special characters in the filename from what i see, but the date format of the files ... file creation date with special characters, so called Umlaute (in German).
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
Please attach a full log file with UTF-8 set to On.
WinSCP should recognize the "Mär".
pipo2
[View user's profile]

Joined: 2015-05-11
Posts: 6
prikryl wrote:
Please attach a full log file with UTF-8 set to On.
WinSCP should recognize the "Mär".


See enclosed full log
logwithutfforcedon.log (8.53 KB) Private file

Description: (none)

logwithutfforcedon.log (8.53 KB) Private file

Description: (none)

pipo2
[View user's profile]

Joined: 2015-05-11
Posts: 6
pipo2 wrote:
prikryl wrote:
Please attach a full log file with UTF-8 set to On.
WinSCP should recognize the "Mär".


See enclosed full log


I have uploaded the logs for you.

What I have noticed is following.

> 2015-05-13 13:15:19.819 FEAT
< 2015-05-13 13:15:19.859 500 'FEAT': command not understood.
> 2015-05-13 13:15:19.859 OPTS UTF8 ON
< 2015-05-13 13:15:19.894 500 'OPTS UTF8 ON': command not understood.
. 2015-05-13 13:15:19.934 Connected

My Server however supports UTF8


LANG=de_DE.UTF-8
LANGUAGE=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
pipo2
[View user's profile]

Joined: 2015-05-11
Posts: 6
pipo2 wrote:
pipo2 wrote:
prikryl wrote:
Please attach a full log file with UTF-8 set to On.
WinSCP should recognize the "Mär".


See enclosed full log


I have uploaded the logs for you.

What I have noticed is following.

> 2015-05-13 13:15:19.819 FEAT
< 2015-05-13 13:15:19.859 500 'FEAT': command not understood.
> 2015-05-13 13:15:19.859 OPTS UTF8 ON
< 2015-05-13 13:15:19.894 500 'OPTS UTF8 ON': command not understood.
. 2015-05-13 13:15:19.934 Connected

My Server however supports UTF8


LANG=de_DE.UTF-8
LANGUAGE=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=


Any news on the issue?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
I have responded to your email.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
This issue has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1328
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License