Multiple connections per file transfer does not work.

Advertisement

Guest

Multiple connections per file transfer does not work.

The previous version (5.9.6) had a option to "Transfer each file individually on background by default." This made WinSCP create a completely separate connection for each file being transferred. The new version (5.11.1) has replaced this with a "Use multiple connections for single transfer" option. The new one sounds like it should be an improvement, since it would allow you to use several connections for each file being transferred. Unfortunately, it neither replicates the previous behavior or performs the stated behavior; it simply creates a single connection for the entire file transfer.

I have a server that has a 100 Mbps connection, but (perhaps due to latency) I can only get 450 kBps connections to it. I can, however, create multiple connections until I've saturated the link between myself and the server. In the old version of WinSCP, I could transfer up to 9 files concurrently, each of which would max out around 450 kBps for a total of about 4 MBps. With the new version, it tosses all the files into one transfer and the total speed is just 450 kBps. If I select one file to transfer at a time, then I can get it to display the previous behavior, where it produces multiple concurrent file transfers. I've experienced this with both the SCP and SFTP protocols on Win10.

Also, I'd really like to see a higher max connection limit.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,097
Location:
Prague, Czechia

Re: Multiple connections per file transfer does not work.

How long does the transfer that you refer to take?

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Guest

I did this test using the latest version (5.11.2) and created 8 files each with 128 MB of random data for a total of 1 GB of stuff to transfer in one batch. I just selected all 8 files, then used drag & drop from the server pane to the local pane to start the transfer. According to the log, it took 42.5 minutes to complete the transfer for an average of 410 KBps.

Reply with quote

Guest

Ok, that seems reasonable; and yet was completely unexpected. Could I suggest adding some sort of notification to WinSCP when the user tries to enable an incompatible set of options like that? Maybe a warning icon next to the transfer that you can hover over to get an explanation.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum