Generate Session URL/Script NOT working

Advertisement

fncruz
Joined:
Posts:
5
Location:
USA

Generate Session URL/Script NOT working

I am new to WinSCP. I am now successfully transferring files from a ftp server manually. I would now like to automate with a batch file.

When I go to Generate Session after manually transferring files it only has the default. It does NOT add the commands that I just ran manually.

Am I doing something wrong?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,073
Location:
Prague, Czechia

Re: Generate Session URL/Script NOT working

To generate a script for a transfer, select the files, go to Files > Upload/Download and on the transfer options dialog go to Transfer Settings > Generate Code - i.e. before a transfer, not after a transfer - your actually do not need to transfer anything.

Reply with quote

Guest

Can't generate code

Martin,

I have version 5.13.7 which I think is latest.
When I go to File -> Download -> Download and Delete, I do not see anywhere any options to generate code.

What am I missing?
Thanks!
FC

Reply with quote

supermankelly
Joined:
Posts:
6
Location:
Essex

Supplied code not working.

I have tried the Batch script and command line for a WebDAV connection and the code provided doesn't connect. It connects fine to the WebDAV server in WinSCP obviously else I could not generate the code. Log path updated as required.

I get same error if run the Batch, Command Line, Script or the VB Net code.

. 2019-08-15 09:29:22.193 Identity match for 'cert.staging.web.XXX.XXX.net': good
. 2019-08-15 09:29:22.193 Verifying certificate for "IT, XXXX Ltd, NA, London, UK" with fingerprint XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX and 08 failures
. 2019-08-15 09:29:22.220 Certificate verified against Windows certificate store
. 2019-08-15 09:29:22.220 Using TLSv1.2, cipher TLSv1/SSLv3: ECDHE-RSA-AES256-SHA384, 1024 bit RSA
. 2019-08-15 09:29:22.220 Request sent; retry is 0.
. 2019-08-15 09:29:22.262 [status-line] < HTTP/1.1 404 Not Found
. 2019-08-15 09:29:22.262 Header Name: [content-length], Value: [400]
. 2019-08-15 09:29:22.262 Header Name: [date], Value: [Thu, 15 Aug 2019 08:29:21 GMT]
. 2019-08-15 09:29:22.262 Header Name: [server], Value: [Apache]
. 2019-08-15 09:29:22.262 End of headers.
. 2019-08-15 09:29:22.262 ah_post_send (#0), code is 404 (want 401), WWW-Authenticate is (none)
. 2019-08-15 09:29:22.262 Request ends, status 404 class 4xx, error line:
. 2019-08-15 09:29:22.262 404 Not Found
. 2019-08-15 09:29:22.262 Request ends.
. 2019-08-15 09:29:22.262 sess: Destroying session.
. 2019-08-15 09:29:22.262 sess: Closing connection.
. 2019-08-15 09:29:22.262 sess: Connection closed.

UPDATE 16/08/2019 - OK so I got it working in VB Net and the WinSCP generated code doesn't work as it is missing user password and port number. and needed WebdavRoot set although in VB Net code this is referenced in the GetFiles call.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,073
Location:
Prague, Czechia

Re: Supplied code not working.

supermankelly wrote:

UPDATE 16/08/2019 - OK so I got it working in VB Net and the WinSCP generated code doesn't work as it is missing user password and port number. and needed WebdavRoot set although in VB Net code this is referenced in the GetFiles call.
Your other post:
https://winscp.net/forum/viewtopic.php?t=25410#93595
And FAQ:
https://winscp.net/eng/docs/faq_script_vs_gui
Though, if you still believe that WinSCP fails to include password and port number into the generated code, please post more details.

Reply with quote

Advertisement

You can post new topics in this forum