disable "filepart" through Winscript when running through SSIS , execute process task

Advertisement

Pranjal Mudholkar
Guest

disable "filepart" through Winscript when running through SSIS , execute process task

Hello ,

We have an issue sending large files > 100 kb using sftp connection through ssis - where the transfer fails & files deployed at sftp have ".filepart" extension added to it.
The commands used are passed as an argument file to ssis - execute process task to open Winscript bat file.
The commands are as below -

option batch abort
option confirm off
open sftp://user:password@servername:port -rawsettings SendBuf=0 -hostkey="xxx"
cd /../testdirname/
put "\\filepath\filename.txt"
EXIT

The error we are getting is as below hen we run the ssis through sql server agent -
Cannot overwrite remote file '\..\testdirname\filename.txt.filepart'. Press 'Delete' to delete the file and create new one instead of overwriting it. No such file or directory. Error code: 2 Error message from server (en): File not found (D)elete, (A)bort, (R)etry, (S)kip, Ski(p) all: Abort Microsoft (R) SQL Server Execute Package Utility Version 12.0.4100.1 for 64-bit Copyright (C) Microsoft Corporation. All rights reserved. Started: 4:06:48 PM Error: 2020-04-15 16:09:58.60 Code: 0xC0029151 Source: dynamic - Execute Process Task Execute Process Task Description: In Executing "\\dirname\OpenWinscp.bat" "test.txt" at "Winscriptdirname\WinScripts", The process exit code was "1" while the expected was "0". End Error DTExec: The package execution returned DTSER_FAILURE (1). Started: 4:06:48 PM Finished: 4:09:58 PM Elapsed: 190.297 seconds. The package execution failed. The step failed.

I am successfully able to suppress "filepart" through command line using the above mentioned commands & the transfer is successful.

It's as if the server fails to respond & Winscript is asking the client process whether to reconnect after the connection interrupts.

Any guidance is appreciated as we will need SSIS called through SQL server agent for this.
Thank u
Pranjal

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Re: disable "filepart" through Winscript when running through SSIS , execute process task

Sorry, I do not understand the problem. You wrote that you were able to "suppress "filepart" through command line". So what is your problem now? Are you asking why the problem happens in the firstplace?

Reply with quote

Guest

Re: disable "filepart" through Winscript when running through SSIS , execute process task

martin wrote:

Sorry, I do not understand the problem. You wrote that you were able to "suppress "filepart" through command line". So what is your problem now? Are you asking why the problem happens in the firstplace?
which

Hi Martin ,

OK to explain more clearly ,
We need to get SFTP working with the below flow -
Sql server job agent calls SSIS execute package (.dtsx)
The commands mentioned are part of an argument file passed to "Execute Process Task" which uses WinSCP.com.

I feel it is not retaining optimize buffer setting or resume support OFF (or 2 which should suppress the filepart) in the above scenario.
I tried using .INI file with below configurations changed :
ResumeSupport=2 (also tried 0)

Somehow the common error I observe is :
Host is not communicating for more than 15 seconds.
Host is not communicating for more than 15 seconds.
Still waiting...
Note: If the problem repeats, try turning off 'Optimize connection buffer size'.

Warning: Aborting this operation will close connection!
(A)bort (56 s):
\...\pranjal15.txt | 99 KiB | 5.0 KiB/s | binary | 100%
Network error: Software caused connection abort

We are trying to drop the file to a Salesforce managed FTP
Still no luck !

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Re: disable "filepart" through Winscript when running through SSIS , execute process task

To disable the resume support use:
put -resumesupport=off "\\filepath\filename.txt"
See https://winscp.net/eng/docs/scriptcommand_put#resumesupport

If you still have problems, please attach a full session log file (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Advertisement

You can post new topics in this forum