note: if the problem repeats, try turning off 'optimize connection buffer size'

Advertisement

DazAK1984
Guest

note: if the problem repeats, try turning off 'optimize connection buffer size'

Hi,

I am getting the following error when running a send file push via a batch command to an SFTP location externally. "note: if the problem repeats, try turning off 'optimize connection buffer size'

I can perform the data transfer successfully manually by the WinSCP application. When running it via the command line from a batch file it give me the error on a file larger than 1mb. Anything smaller works fine. I have tried with the following:
#Start Script Code
Option confirm
open sftp://*******:***********@***********.com/incoming/20201201/
put \\******\London\FTPData\Dev\ -resumesupport=off -rawtransfersettings SendBuf=0 SshSimple=0
close
exit
#end script
I am buffled and don't believe this is a network issue as it works via the gui without any changes within the GUI.

Any help ASAP would be greatly appreciated.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,066
Location:
Prague, Czechia

Re: note: if the problem repeats, try turning off 'optimize connection buffer size'

The settings though go to the open command:
open sftp://.../ -rawsettings SendBuf=0
Though if you believe the problem is different, please attach session log files both form the GUI and the script.

Reply with quote

DazAK84
Joined:
Posts:
3
Location:
London

Attaching Logs

thanks,

I have added the recomemndation:
#Start Script Code
Option confirm
open sftp://**********:********@******.*******.com/incoming/20201201/ -rawsettings SendBuf=0
put C:\SFTP\*
close
exit
#end script
attaching the log file as it still fails. It works via the GUI without issue. Also works from outside of my domain environment.
Last edited by DazAK84 on 2021-02-09 13:16; edited 3 times in total

Reply with quote

martin
Site Admin
martin avatar

Re: Attaching Logs

So please attach a new log file. As well as a log file for "works from outside of my domain environment".

You should change your credentials, as you have posted them publicly.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum