Multi-file background transfer doesn't work

Advertisement

konstbel
Joined:
Posts:
8

Multi-file background transfer doesn't work

Hello.
I have setting "Maximal number of transfers at the same time" = 9 and expected, that when I transfer a directory (in background), 9 files from it will be transferred at the same time. But this is not the case: only 1 file is transferred ((
But if I manually split the files between 9 tasks – they all will work together.
What I do wrong? Why single background task is not distributed among 9 transfers?

Capture.PNG

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,884
Location:
Prague, Czechia

Re: Multi-file background transfer doesn't work

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

konstbel
Joined:
Posts:
8

Re: Multi-file background transfer doesn't work

Making some experiments, I've found the source of problem.
I've started several background tasks, one of them realized (!) multi-file transfer, others -- not :((. The difference was in Transfer Settings.
The one, that performs multi-file transfer, had default "New and updated files only" settings, the others have added "Preserve timestamps, Including directories" and have "Exclude directories" file mask set. As I just added the file mask, I think that the problem is in "Including directories" option.
Am I right?
By the way, why only 9 transfers available?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,884
Location:
Prague, Czechia

Re: Multi-file background transfer doesn't work

Yes, multiple connections are not used, when preserving timestamps of directories is enabled:
https://winscp.net/eng/docs/ui_pref_background#fn1

You can increase the limit beyond 9 with raw configuration option Interface\QueueTransferLimitMax:
https://winscp.net/eng/docs/rawconfig#queuetransferlimitmax
But I do not recommend it for stability reasons.

Reply with quote

konstbel
Joined:
Posts:
8

Yes, multiple connections are not used, when preserving timestamps of directories is enabled
Hmm... You have to print this with BIG letters, and add some message or/and checkbox hint for this option. I've spent a lot of time, trying to understand what's going wrong!

You can increase the limit beyond 9 with raw configuration option Interface\QueueTransferLimitMax. But I do not recommend it for stability reasons.
OK, thank you. Is there a way to speed up the directory listing?
I have a slow source with >500k files, and this takes a while (several hours). Of course, I can switch off the "Calculate total size" option, but in this case I will not know the transfer progress.
Multi-connection listing? Progress in amount of files, not MBytes?

Reply with quote

Advertisement

martin
Site Admin
martin avatar

A directory listing cannot be read from the middle in general. Definitely not over SFTP. So multi-connection listing is not possible.

Reply with quote

yeung
Joined:
Posts:
3

Re: Multi-file background transfer doesn't work

martin wrote:

Yes, multiple connections are not used, when preserving timestamps of directories is enabled:
...
I tried above configuration. But it does not work. The max connections is still 9. And the configuration in GUI Preferences shows 9 too.

I start WinSCP with
WinSCP.exe /rawconfig Interface\QueueTransferLimitMax=99
Any idea? Thanks in advance.

Reply with quote

Advertisement

yeung
Joined:
Posts:
3

Re: Multi-file background transfer doesn't work

My test is based on WinSCP 6.3.3 (Build 14916 2024-04-16). I believe it is latest version at this moment.
WinSCP.exe /rawconfig Interface\QueueTransferLimitMax=99
Is above command proper way to launch more multiple connections?

Reply with quote

Advertisement

You can post new topics in this forum