Editor creates blank lines

Advertisement

fanta
Guest

Editor creates blank lines

Has anyone realised that editor causes empty spaces in html/php/css etc. files? Everytime I open my files - under each line of text appears empty line, so after opening the same file many times I have lots of empty spaces between each line of code... Does anyone have the same problem? How to solve this?

Thanks.

Example:
#header {



   width: 750px;



   height: 140px;



   float:left;



   background-color:#FFFFFF;


}

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: Editor creates blank lines

What version of WinSCP are you using? What editor do you mean? The internal one? What is your server? What is your configuration of End-of-line characters?

Reply with quote

dzoniboj
Guest

Same problem

I am having the exact same problem, and it just started happening recently.

I've been using WINSCP for around 8 months with no problems like this.

I use sublime text editor and edit html, css and php files.

What can be done?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: Same problem

dzoniboj wrote:

I am having the exact same problem, and it just started happening recently.

I've been using WINSCP for around 8 months with no problems like this.

I use sublime text editor and edit html, css and php files.

What can be done?
What protocol? SFTP or FTP?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Please attach a full log file showing the problem (using the latest version of WinSCP). I.e. connection, open the file in editor and save it.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

dzoniboj
Guest

I enabled logging, connected and directly opened a certain file with blank lines in it.

Hopefully that did it.
  • ultranet@ultranetdesign.net.log (7.58 KB, Private file)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

dzoniboj wrote:

I enabled logging, connected and directly opened a certain file with blank lines in it.

Hopefully that did it.
Thanks for the log. Can I get a test account on your server?

Reply with quote

Advertisement

Knocks
Joined:
Posts:
2

This issue baffled me too for a while, and I even filed a support ticket with my host. The fix was pretty easy, all you need to do is uncheck the following box:



Martin, you might want to disable this setting by default for external editors in future versions.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Knocks wrote:

This issue baffled me too for a while, and I even filed a support ticket with my host. The fix was pretty easy, all you need to do is uncheck the following box:

...

Martin, you might want to disable this setting by default for external editors in future versions.
The option is disabled by default for external editors, except for the default Notepad.
See also this link (posted above already):
https://winscp.net/eng/docs/faq_line_breaks#known_issues

editor_preferences.png

Reply with quote

Advertisement

You can post new topics in this forum