Transfer of ascii data is dropping first line

Advertisement

Serex
Joined:
Posts:
1

Transfer of ascii data is dropping first line

We are using winSCP 4.2.7 attempting to transfer files for our first time thru SFTP. Whether we issue command prompt or run thru an SSIS execute task it does the transfer beautifully, but it drops the first line. The end user insists that the problem is in our data transfer and we have exhausted what to look for. The user said we needed to be sure it was ascii as it was coming thru as binary, but we added that option and it is still happening. The recipient also indicates there are extraneous characters () being inserted at the beginnig of the first line which cause the transfer to drop that line. Can you help?

Here is the script we are executing

option batch on
option confirm off
option transfer ascii
open sftp://username:password@sftp.sitename.com -hostkey="ssh-xxx 0000 xx:00: 00:xx:x0:0x:xx:x0:x0:x0:00:x0:0x:00:x0:0x"
put "\\myfilepath\firstfile.txt" "/HOME/Put/ firstfile.txt"
put "\\ myfilepath \secondfile.txt" "/HOME/Put/ secondfile.txt"
close
exit

execution command line:
"C:\Program Files\WinSCP\winscp.com" /script="C:\Program Files\WinSCP\pospay.txt"

SSIS settings that execute the script the Execute Task Argument is the same as the command line.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Transfer of ascii data is dropping first line

Can I have a copy of the file you are transferring?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum